AX12+ servo not being "seen"

I have 18 AX12+ servos. I acquired them back in 2012 as part a Robotis Hunanoid kit. I subsequent reused the servos to build a hexapod. The servos worked as expected. After a year or so of tinkering, the hexapod was put aside where it rested till I tried to resurrect it this year while I was in isolation. But the servos, that were working back in 2012, I can not get working now. They cannot be “seen” by any controllers.

Working with just one servo to try and isolate the problem, I have it hooked up to a usb2Dynamixel and my laptop running the Dynamixel Wizard software. I have a 12V power supply hooked into the three pin Dynamiel connector to the servo and the common on the usb2Dynamixel.

With this setup, when I plug in the 12V power supply, the AX12+ led blinks once. When I use the Wizard to do a search for the servo it can not be found. When I try to do a firmware recover (after disconnecting and reconnecting the 12V power supply) once again the servo cannot be found.

Im using Dynamixel Wizard Version /

I am stuck. Any thoughts of what I can do next? or where I can get more help?


Hi again, (also answered some on TrossenRobotics earlier),

I think @willson of Robotis mentioned try using the version 2 of the Dynamixel Wizard… Not sure if that would help or not.

Do you have any other controllers, like something that runs Arduino that you used earlier, maybe for your hexapod? Or do you have some form of Arduino that can be setup to talk to these servos? If so I would try setting one of these up instead of the USB2Dynamixel.

I have some of my own earlier libraries or recently started converting over to try to use some of the Robotis libraries, such as Dynamixel2Arduino, which I think you can use the Arduino Library manager to install. With this they have a scan_dynamixel example. However you might have to create a simple sub-class of their code to handle the Serial port if you don’t have a setup like they do… Not hard to do.

If you don’t have something, I would recommend getting an easy to use test setup, like an OpenCM9.04 either the blank one with no connectors and get their connector set, and put on one or more of the AX servo connectors, or their preferred get the standard OpenCM9.04 C(I think) with an OpenCM RS485 adapter boards (which also handles AX servos as well) and then try some of their software like this.


Below is an excerpt from the ROBOTIS Forum thread.

First of all, make sure that your USB2Dynamixel is set to TTL Communication mode.

Since DYNAMIXEL Wizard 2.0 comes with more features and recent update, it is recommended to use DYNAMIXEL Wizard 2.0 instead of DYNAMIXEL Wizard 1.0.

Please try firmware recovery on Wizard 2.0 and let us know how it went.

If they also cannot be detected from the Wizard 2.0, I’d suspect communication chip issue.
I hope you and your family are safe from the Covid-19.

Thank you.