R+Task doesn't recognize the servo


I am using OpenCM9.04 and an extension board to connect my MX servos to R+ Task. I followed all instructions, but the software doesn’t recognize the servo. Would you please advise me?

Hi @SamKh, welcome to the community and thank you for your question. Allow me to request some clarifications and share some links that should be of assistance:

  1. Can you confirm which version of R+ Task you are using? I would recommend R+ Task 3.0 For a full set of basic instructions for the software, we recommend reviewing the R+ Task 3.0 emanual page (emanual.robotis.com). This page features comprehensive instructions to help get you started with the software. R+ Task 3.0

  2. As your first step you should most likely confirm the settings on your OpenCM9.04 board are set correctly to detect your DYNAMIXEL. You will need to connect to our software R+ Manager 2.0 to edit some settings in the OpenCM9.04 firmware.

  3. You will need to follow these instructions using the software R+ Manager 2.0 to correctly detect your DYNAMIXELs when controlling them using the OpenCM485 EXP board: OpenCM 9.04

  4. In addition to the above, you will need to look for a setting named “Baud Rate (Bus)” and edit this to the default baud rate for your DYNAMIXEL (default for MX-series units: 57600).

  5. After this is completed you should be able to detect your DYNAMIXELs from the board using your R+ Task 2.0 software.

  6. For more information, I also recommend reviewing some of the tutorial content available through our YouTube Channel- ROBOTIS Customer Support YouTube. Our R+ Task 3.0 tutorial playlist may be helpful to assist you in getting started with the software as well.

Let me know if you have any questions or if anything above could use clarification.

Happy Cheers GIF by HeyAuto