RX-28 is not detected

Servo model: RX-28
Setup: DynamixelShield on ArduinoUNO. Debug serial using another ArduinoUNO as UART-Serial bridge.
Situation: I recently purchased the DynamixelShield for a project to control a couple of RX-28s that I had from another project. This decision came after I was unable to even detect the motors using a self-made RS-485 to USB converter, though this same setup worked on that earlier project. I assumed that the converter is broken as the cables were pretty worn-out and bought the shield. Then when I tried to scan one of the motors using scan_dynamixel example code, nothing showed up. The power supply was set to 14V as recommended and the even the motor blinks once when powered on, which is normal. But after that, nothing works nor there are any LED indications of a particular error. Just as a control experiment, I connected an AX-12 that I borrowed from another robot, which got clearly detected with the same scan_dynamixel example code. It’s pretty evident that the issue is with the RX-28 motors. I’m not sure how to debug this to get them working as they are not even discoverable to maybe factory-reset them or something. Any help from the Support team or anybody from the community will be appreciated, thank you.

1 Like

I have no experience with the RX-28, but maybe you operated them at a lower baud rate in the previous project?

The scan_dynamixel code seems to scan for nothing lower than 57600:


So if you add the lower rates of 19200 and 9600, maybe the RX-28’s are found…

1 Like

Thank you. I’ll check this and report back.

Meanwhile, I had also posted this issue on ROBOTIS-GIT and there I received another suggestion that the DYNAMIXEL2Arduino library deactivates some discontinued DYNAMIXEL series in order to save the memory space in some boards.
To enable the RX-28, one can set the ENABLE_ACTUTATOR_RX to 1 in the setup below.

Unfortunately, the suggestion from git didn’t make any difference for me but I thought it could help someone else with a similar problem.

EDIT: I did check with lower baud rates, but the motor is still undetectable. How do I approach this now, anymore suggestions.? It would’ve been so helpful if there was a way to hard-reset the motors. Is there any.? Thank you.

I do all my “maintenance” (setting ID’s, checking parameters, …) on the servos with the DYNAMIXEL Wizard 2.0 and connect the servos with the U2D2 in combination with the U2D2 Power Hub. The “Wizard” has several recovery functions, may be you could check-out if anythings sounds right for your problem.