XL430 not working suddenly


I am working on a project with multiple dynamixel XL430-W250-T with arduino MEGA and dynamixelshield.

I was working with the example file “id” that gave me weird characters at first. After trying different ways like changing baudrate and trying Visual Studio Code to run it, I found out that I had no serial connection back to the PC with LN101. However, now once I run the example file “velocity_mode” or “position_mode”, the motor no longer moves. I have tried resetting the board and everything, however it didn’t seem to solve the problem. I suspect when I was playing with the ID and VScode, somehow the motor IDs got mixed up. Could you have a possible explanation for this? What are the other ways I could try to reset the motor?

Thanks in advance.

1 Like

Please paste your code for me to look into

Also make sure to flip a slide from “Upload” to “dynamixel” before running your code.

It is the example code from dynamixelshield named after “velocity_mode”

The motor was working fine with all the example code before, which tells me it’s not from the code. But perhaps the motor or the board.

Hello @chris and thanks for joining our Community page! Let me confirm some items and give some suggestions:

  1. If you ran the Dynamixel Shield example named “id” available in the Dynamixel Shield Arduino libraries it’s possible your DYNAMIXEL’s ID number has been changed to “100”. I checked that example and it appears to change the ID to the “new_id” defined in line 66 of the “id” example. It may be worth attempting to change the “new_id = 100” in line 66 to “new_id = 1” to see if this works for you.

  2. With the LN-101, this is meant to connect to the UART port on the shield due to the hardware limitations of the Arduino Uno- to provide a serial connection back to your computer that can be read while the main serial bus of the Arduino Uno is occupied controlling DYNAMIXEL.

  3. However, because LN-101 is a different device than the Uno itself you will need to change the “Port” in Arduino IDE to the COM port of your LN-101 before opening the serial monitor. It should be possible to check using Device Manager which port is which. If you’ve selected the correct port for the LN-101, you should be able to see readable text in the Serial Monitor.

Let me know if any of the above suggestions help!

Hey @chris I just wanted to check in. Were you able to resolve the described issue with your DYNAMIXEL XL430-W250-T?

hello @Andrew!

Thank you for your help! It was definitely the id issue. I was able to solve by scanning the motors that identified each motor’s id and individually changed them to the id that I wanted.

1 Like