About powering dynamixel through openrb150


I am trying to connect MX-106T to OpenRB-150. I input the power through VIN pin, not terminal, as 12V. However it looks like there are no power at the dynamixel side. Current after connecting dynamixel is 0.03A. Power source jumper is for using USB or VIN. I also tested through terminal block with proper power source jumper. It was the same.

Do you expect any problem?


According to the Robotis e-manual web info, the VIN pin is supposed to use 5V


Thus by putting 12V into the VIN pin first, you may have done something to your OpenRB-150 already? This may explain why even now using 12V through the Terminal Block does not work at present?

Thanks for your reply.

But I have several OpenRB-150s, and I tried with a perfectly new one to input the 12 V through the input terminal. But it did not work. So I thought that I missed something for initiating the board. I ask the question again here. Should it work without any initiating processes?

The other question is about the support voltage on the VIN pin. Are you sure the VIN pin cannot support 12V? Because I checked that the VIN pin supports 12V in the table of the manual. I already designed my customized PCB board based on that table. So, if the VIN pin doesn’t support 12V, I must modify the PCB design and order again. Please find the capture below.

In that case, please try to use around 11-11.1 V as input voltage. I had some older OpenRB-150 that would not work at 12V but worked OK at 11V. But supposedly that issue is resolved by Robotis by now.

Some more details in this older posting

Thanks for your reply.

I tried to input 11V and an even lower voltage. It was not working. I found that if I input 11V to the perfectly new OpenRB-150 (just after putting it out from the sealed box), the DXL LED is turned on, and the voltage from the DXL port is around 10.5V. However, after I upload the “usb_to_Dynamixel”, the voltage at the DXL port starts to drop, and the voltage never increases again if I turn off the power and turn it on again. Do you have any ideas about this issue? I tried this with 3 OpenRB-150.

I solved this problem by inputting the voltage separately to the Dynamixels. It works with the example code “usb_to_Dynamixel”, and I can access the Dynamixel manager software. However, this is not a normal way.

This seems to be a “new” problem that I did not encounter before. I am sending notice to @Jonathon and @willson now to see if Robotis has knowledge of this issue.

In my older post, I also mentioned that I needed/preferred to power my 12V actuators separately and just control them from OpenRB-150 or the U2D2 only.

By the way, what is the QC number on your RB150s?

Thanks! The QC number is 2320.

My QC number is 2234, so yours RB-150 is newer than mine. And I do not have any problem with using XL-430s via the VIN Terminal Block, see my output below:


So this definitely looks like a “new” issue for RB-150. So I would suggest contacting Robotis directly for help, via @Jonathon if you are in the USA.

Also I forgot to mention that I preferred to have separate power for the actuators and control them via 5V TTL only through the RB-150, so that any possible power kickback from the actuators won’t go through the RB-150. Previously I had the issue of having an XL-330 going bad on me (after a year of usage - so I can’t complain there) but it also destroyed 2 other XL-330s and the controlling RB-150. So I had learned my lessons the hard way too.