Bioloid Premium humanoid bot remote controller not working

Hi there,
I recently acquired a Bioloid Premium humanoid robot (cm530 controller and AX12a servos), but I’m encountering some issues that I could use your help with:

  • I attempted to upload new code to the controller, but after that the robot no
    longer responds to commands from the remote controller (default ones, for example U for forward motion). Could you provide guidance on what adjustments I need to make to regain control of the robot
    via the remote controller?
  • I’ve noticed that R+ Task3.0 software functions on some laptops but not
    others. Can you assist me in resolving this inconsistency?

I would greatly appreciate anything you could recommend to
help address these issues.

Thank You

You must download the task and motion files appropriate for the robot you created.

For humanoids, please refer to the remote control operation method.
In particular, check whether the IR receiver is installed on the CM530 controller and the remote control channel settings.

I tried uploading the task codes given in the emanual but they fail to get uploaded on the CM530 controller.

I also tried uploading the default task code already given in Robotis Premium → Default → Humanoid A Type, in the R+ task3.0 but the bot is only moving forward irrespective of I press U, D, L, R or any other combination.

Any idea how I could correct that?

Have you tried the older tools? TASK 2 and MOTION 2?

Yes I did and it worked successfully. I had to use R+ Motion2.0 and R+ Task2.0. Whatever change I was making on the R+Motion2.0 was successfully getting reflected in the CM530 controller.

Thanks!

Glad to hear that you can enjoy your robot now!