CM-150 won't connect to Rplus Task

Use the following template to help create your post:

  1. ROBOTIS Dream II Level 3

  2. Rplus Task 3.0

  3. I have an HP laptop. I do use Windows 11.

  4. I’m trying to download the Security Robot example to my CM-150. An error keeps popping up saying “The semaphore timeout period has expired.” This message pops up when I try to connect using the regular connect button. When I do auto connect it just says failed to connect robot.

1 Like



Try the following,

  1. Make sure that your CM-150 is properly detected by your COM port. If not, try to install the virtual COM port provided by ROBOTIS. See how to install Virtual COM port. (e-Manual does not mention Windows 11 is available for the virtual port, but it is possibly okay to use in Windows 11)

    • Reference: How to check

      • Go To Device Manager > Expand the tree of Ports > Find your Controller Serial Port
        (COM #number)


  2. Finding out you are okay at #1, Your controller should be ready for code download.

    • Hold down the Start Button centered on the top of the controller for 1 sec until hearing double beep sounds. This will let the CM-150 enter the Manage Mode which enable programming download. (aka Bootloader)


Thank you so much for replying. I tried downloading the Windows Driver folder. However. my laptop will not download it. Is there maybe another link I can use to download it?

Actually, I got it to find the CM-150 on a desktop. Now my only question is once it finds the CM-150, when I try and download the program it only pulls up the connect screen and the only option from there is to disconnect. If anyone could let me know how to properly download the program that would be great. Thanks in advance!

1 Like

Have you tried to run Task in Windows Administrator mode?
Also, sometimes you have to restart the COM port procedure - disconnect and then reconnect to make the download connection to work. Or you also can get out of TASK completely and re-run it to clear all these COM Port issues.

@nancyzg @willson @Yogurt_Man
Update: I have a Lenovo Legion PC previously on Windows 10 and I just update it to Windows 11 today.

On Windows 11, I have tested MANAGER 2 and TASK 3 on a CM-150 and both so far had worked OK for me. I did not have to run TASK 3 as Windows Administrator.

However, when I used TASK V. 2.3.9 on the same CM-150, I had found that I had to run TASK 2 as Windows Administrator to get it to download any code, then TASK 2 would hang up in the process, or it would say right away that it could not find any controller.

1 Like

Hi, @roboteer,

I’ve found current version of R+ Task 2.0 (v2.3.9) got an inssue on downloading unless it access as Admin. Our engineer has been working on it and the resolved one will be updated soon.

Thank you so much for your attention !

Once the R+Task 3.0 connects CM-150, you will see your device port is properly shown in the ribbon menu (1). Then you should click on the Download button.

I highly recommend to reference e-Manual.