Connecting MX-28R (4pin) by U2D2

Dear All,
I’m trying to connect MX-28R (4pin connection) by using U2D2 from Dynamixel to change the ID for the servo without any luck. I tried both Dynamixel Wizard 2.0 and R+ manager. I tried more than four MX-28R (4pin) and also I tried RX-28(4pin).

I can connect my U2D2 with MX-28T(3pin connection) and change the ID for this 3 pin servo.
Is any suggestion what is the problem with my 4pin connection servos and any solution for that?
I appreciate any help!
Thank you!

1 Like
  1. As far as i know, there is a diode in old MX Series. And if this is damaged, the communication error could be caused by. In this case, use repair service by ROBOTIS.

  2. Attempt Firmware Recovery

  3. Scan the DYNAMIXEL by selecting options as follows.

Thank you for your reply!
The problem is not with a specific motor as I mentioned in my previous post. I tried many motors with 4 pin connection and I could not connect with any of them. I changed the U2D2 to new one and the same problem.
However, I tried to make a firmware recovery but could not detect the motor.
Is any other reasons why I can’t connect to 4 pin motors (RS 485) and in the same U2D2 I connect to 3 pin motors (TTL)?