Control issue of OpenMANIPULATOR-x using OpenCR



Control Environment

SMPS 12V5A is connected to power connect on OpenCR and Openmanipulator-x is connected to OpenCR using TTL cable as instructed.

Hardware Description

I’m trying to control OpenManipulator-x using openCR via Arduino and processing as instructed in the e-manual.

Issue Description

I’m having issue with controlling openMANIPULATOR-x using OpenCR board and graphic GUI created by Processing.
OpenCR works fine(I tested the openCR board using simple example codes) and all openMANIPULATOR joint torques has enabled after I push ‘reset’ button on OpenCR. In ‘joint space control’ tab in the GUI, openMANIPULATOR simulator follows well as I change each joint angle. However, when I click ‘send joint angle’ button, the physical real openMANIPULATOR-x never changes its configuration as I configured in the simulator. All other tabs in the GUI doesn’t work.

Please help me out. Thanks!

Thanks for reporting the issue.

Could you elaborate more on your development environment?
Such as types of OS, the version of processing, etc…

I’ll try with my set up and let you know.


Hi @willson ,
I am currently using Windows 11 and trying to control the manipulator using Arduino. We are currently using Processing 4.2.
The manipulator can be controlled when connected through U2D2 microcontroller using Dynamixel Wizard 2.0 (motors were scanned in the Dynamixel Wizard 2.0), shown in figure below.

But we are unable to do the same using OpenCR (motors are not being scanned in the Dynamixel Wizard 2.0), hence we are not able to control the torque and the IDs are not getting recognized.
We tried to upload the usb_to_dxl file from the arduino ide to openCR, as shown in figure below

The Dynamixel Wizard 2.0 was not able to recognize the motors, shown below.

We tried scanning for all the baud rates and still wasn’t able to get the connection.
Please let me know if there is any other info that is required.
Thank you!