Dynamixel Wizard 2.0 Can't Recognize Motors

I am trying to connect all of my motors using Dynamixel Wizard 2.0 so that I can check and change their IDs. The ID for the MX-28R motor I current have is 1, and I want to be able to change it to 0, but it won’t recognize.

Use the following template to help create your post:

  1. What model of servo are you using?
    I am using a RX-28R and a MX-28R

  2. Describe your control environment. This includes the controller or interface, and any power source.

    This is my set-up with a 13.4 power supply connected to the motor and the USB2Dynamixel adapter.

  3. Specify the operating mode for applicable models, and any firmware settings you are using.

  4. Include pictures if possible.

  5. Include a full description of the issue.
    -The driver is downloaded and recognized by the computer as COM7
    -We have completed a full sweep of all possible IDs and Baud Rates
    -We have tried to do a firmware reset but it returns two errors.
    For the MX-28 Servo it returned a “Firmware Transfer Failed”

    For the RX-28 Servo it returned a “Bootloader Error”

Any help would be greatly appreciated!

1 Like

The first picture is aimed for RX-28, not MX-28. Check out you’ve tried to update the firmware with proper model of DYNAMIXEL. (Although this has nothing to do with your issue)

When performing the Firmware Recovery, make sure you’ve only connected one DYNAMIXEL to PC. Otherwise, you will fail to get a new firmware as the data in serial cable will be confused where to update.

The two photos you posted are showing firmware restores for two different servo models, are you experiencing issues with both of the units?

Generally if it is not possible to perform a firmware restoration of a nonfunctional DYNAMIXEL unit, that’s a good indicator that the actuator needs to be sent in for RMA service.

I am not experiencing any issues with the RX-28 motor, that one has had it’s ID changed and works completely fine.

The one I am trying to change is the MX-28 motor.

What I was doing was trying to see if either of them would be recognized by the Dynamixel Wizard, which neither would.

Thank you for the tips, I hooked up two separate motors on two separate tests. Both of those motors were set up properly and I still got the same results.

1 Like

Unfortunately, this seems to be an issue with the comm chip in DYNAMIXEL. You should proceed to Repair service by ROBOTIS.