Error setting up Python 3.12.3 with Dynamixel SDK on Windows 11


I am currently having an issue with setting up Python 3.12.3 with the Dynamixel SDK.

I am using the following videos as reference: → Part 1 → Part 2

I’ve tried to troubleshoot this issue with two versions of the SDK. I have originally downloaded the Dynamixel SDK v3.7.31 from the Dynamixel webpage but referring to the part 1 video, the user downloads the Dynamixel SDK - Master which is the v3.7.51 from the GitHub.

Next I downloaded the latest version of Python 3.12.3 from their website. I also downloaded the Python 3.12 app from the native Windows 11 app store.

This is where I encountered my first error [Resolved]:
importerror "No Module named Setuptools" → when trying to run install when trying to run in command prompt

Solution ⇒ python -m pip install -U pip setuptools

Link: Python 3: ImportError "No Module named Setuptools" - Stack Overflow

Second Error [Unresolved]:
Untitled (4)
Untitled (5)

I’ve tried to run a test code to see if it would work, however, it’s telling me that I don’t have the Dynamixel SDK. However, looking at my folders, it is there. I believe that I can’t run any sample codes since I haven’t resolved the issue.

Untitled (6)


DYNAMIXEL Controller:

MOXA Nport IA5450A and 5100A

Software Interface:

Dynamixel Wizard 2.0