How to report a bug with CM-550 firmware

Ok I have found a bug with the CM-550 controller. I am programming it in python using task 3.1.6.

The issue is if I down load a program and run it then it works fine but if I power down the power up again many of the dynamixels don’t work until I re-download the program again.

First I was developing the code with both the main power connected(without battery) and the USB connected so everything worked fine. After I unplugged everything then plugged the battery in and tried to run it as stand alone the program ran fine but many of the dynamixels didn’t torque on. I tried reconnecting the main powers and still the same out come. I tried reconnecting th USB to computer and still same problem. As soon as I down loaded the program again it all worked. I tried repeated power down and power up cycles and always the same result whether using battery power or mains power.

I found I can run the robot fine off battery power if I power up via battery the connect USB to computer and down load then disconnect from computer and run as stand alone but any time I turn off the robot then I will need to re download the program again before all dynamixels work.

Hello @Out_of_the_BOTS, thank you for your questions and for bringing this to our team’s attention! Allow me to request some additional information to clarify:

  1. Can you share what error message or result the software shows when the download fails? This could help us look into this further.

  2. Have you had the opportunity to attempt to update the CM-550 firmware using ROBOTIS’ R+ Manager 2.0 software?

2.A) R+ Manager 2.0 can be downloaded from the ROBOTIS Software Download links post in our Reference Links category

2.B) The ROBOTIS e-Manual contains instructions for R+ Manager 2.0 which may be helpful to reference as well: R+ Manager 2.0

  1. To confirm, you mention that the code ran correctly with the DYNAMIXELs torqued “on” the first time, but have been unable to repeat this without re-downloading the code?

3.A) This may be related to how the CM-550 runs its downloaded code- directly after download it should trigger code to run, however after turning on the controller from power-off, the CM-550 will need to be put into “Play” mode and have its “Start” button pressed before code will run.

3.B) Can you confirm whether this has been attempted? This screen capture from the CM-550 e-Manual shows the button locations:

3.C) For instructions on how to set the mode of the CM-550, please see this linked description of CM-550 operating mode. After turning on the controller, you will need to press the “Mode” button until the button lights up green. Once the “Mode” button is green, press the “Start” button on the other side and the controller should begin running code.

For some additional advice or other opinions, allow me to tag our member @roboteer who has experience with CM-550 as well.

  1. I only get message download failed without any debug see the video I made to show it here

  2. just tried Manger 2.0 and clicked on update and it updated the dynamixels but didn’t do anything to the CM-550 see

after the upday was complete this is what I got

There was a firmware recovery but I never clicked that button.

  1. I tried to make a video showing the problem, it is probably not the best video but you can request for me to video some more tests if you want.

Now I assume there is some sort of handshake the CM-550 has to do with the dynamixels before it can operate them. I my code I don’t have to call any init function for the dynamixel so I assume this is already done by firmware when the CM-550 boots up. Now if you look in the video it doe seem to make a difference to whether the CM-550 boots up by power of USB or boots up by power mains/battery