I cant control my ax-12a

Hi, I come back again. You can see the picture, I connet the ax-12a with my computer, and I use" Dynamixel wizard 2.0" to scan the ID, but the line is empty(which should have id number and model of motor). Also I had success to scan the id and model of ax-12a with same means of connet three month ago.
And at Arduino end, I know the id and baudrate of my ax-12a , but when I upload the example program, it doesn’t work.
I has change the computer , power ,3p line, system(ubuntu),even ax-12a, but all doesn’t work.

The process of things is like this.
First,most import thing is I want to control my ax-12a ,but failed. So I want to scan the ax-12a in dynamixer wizard to find out what happend,but the line is empty. I change the required items of connet, all doesn’t work.

I would like to know what happend?
Thank you!

What is the brand and model number of that USB to TTL module that you are using? Does it convert USB to half-duplex like the U2D2?

I am very happy to tell you the information, because the one pin of TTL is failed, I think my soldering error the few days ago caused this to happen. Now I can control my ax-12a with OpenCM9.04.
But the unscannable situation still exists, I don’t know what cause the problem. I gusses maybe the USB to TTL is failed. But I had success reset ID of my ax-12a before with same model.

My module of USB to TTL is a small brand. I don’t know if it can convert USB to half-duplex like the U2D2.Because I don’t have U2D2 now. But I convinced it can help me scan the ID the premise is the module is intact.

Thanks for your reply.
Hope you have a nice day!

Can you show a screenshot of Dynamixel Wizard when you tried to connect to the AX12 via your USB-TTL converter? Is this USB-TTL converter named USB2AX? Like shown below:

Good afternon,Sir. I use the converter as above. I gusses maybe it failed. Now,I can control my AX-12a, so I’m not eager to solve this problem now.

And, when I scan my ax-12a by the converter, the Dynamixel wizard is no response, the line is empty ,just like the above. I gusses the converter is failed. Because the 3pinTTL ,ax-12a, and power and other, all intact.

Two days ago I wanted to scan the ID of the servo because I didn’t find the reason why I couldn’t control the servo, now I solved this problem. So if I want to change the ID or else of ax-12a, I will buy a new converter, but now I haven’t demand.

Thanks for you reply.
Hope you cuold have a nice day!

Thanks for sharing this info about USB2HDXL. It looks like that it should work like the U2D2 ie converting from full to half duplex.