I can't control my AX-18A with Dynamixel shield


DYNAMIXEL AX-18A, Dynamixel Shield, and Arduino Uno

Issue Description

Hi, I want to use my Dynamixel Shield with Arduino Uno to control Dynamixel AX-18A but I can’t get it to work.

What I have done is:
-Placing the shield
-Connecting the Uno to my PC (windows)
-Using SMPS arduino to power it up (I didn’t remove the VIN cap)
-Connecting the AX to the Shield with robotis cable
-Using examples (led, position, and others) and have successfully uploaded it
-Turning both of the shield switches to dynamixel mode
-The LED on the AX blink once with red colour (I assume it’s a sign it was powered)
-Nothing happens after that, I can’t blink its led nor moving the servo

I own a CM-530 and I have tested that the servo is working and the ID is correct. I don’t own LN-101 sadly, so I can’t see what it says on the serial monitor. But when I opened the serial monitor it does printed something (garbled output). About the code, I use the example code and only change the id number. I use the latest arduino ide and also the latest DynamixelShield and Dynamixel2Arduino library.

Additional Information/Attachments

My wiring pict and results of running scan example (I have no LN-101).

Thank you in advance.

Unfortunately, without the LN101 the serial output isn’t very helpful, but I do have another suggestion that may resolve your issue.

In the example sketches for DYANMIXEL Control there should be a line about the DXL protocol version. By default, it is set to use protocol 2, but AX servos only support protocol 1. If you change the line to refer to protocol one as shown in the example below it may allow you to control your servo.

const float DXL_PROTOCOL_VERSION = 1.0;

Hi, thanks for the reply.

I did change it into protocol 1.0 but still not working. Anyway I did some test with my AX-12+ and I managed to blink its led and move its servo. Apparently I have to insert a correct baudrate, which is 1Mbps for the AX-12+.

But for my AX-18A, I did try to input every common baudrates but still not working. Is there a way to check my AX-18A baudrate without using LN-101?

You may be able to fix the baud rate issue for the AX-18 via the older Manager V.1 tool (part of the Robotis Software Suite V.1) and your CM-530 - Use “Detailed Search”.

If the above procedure does not work, you may have to do firmware recovery on the AX-18 using Dynamixel Wizard V.1, and then you would need the USB2DYNAMIXEL dongle which is no longer sold by ROBOTIS. Other folks have used the USB2HDXL instead:


Or you can get the U2D2 from Robotis.

1 Like

Sorry for late update. Yes, thank you now it worked.

The solution: Using “Dynamixel Search” (not “Detailed Search”) on Roboplus Manager will set all of the connected dynamixels baudrate to 1Mbps. Then change the baudrate on the dxl.begin to 1000000. Works for AX-12, AX-18, and MX-28.

1 Like