Installing ROS Melodic on Raspi4 4GB

I am trying to install Melodic on a raspberry pi 4GB. Following the steps to install the raspi based OS, on boot in the pi I get the error

“start4x.elf: is not compatible
This board requires newer software”

The image that was downloaded directly from robotis was mounted using first rufus and when that didn’t work I tried to use the raspberry pi imager. Both methods produce the same result.

I am using a
Raspberry Pi 4 Model B - 4GB
bootloader: c2f8c388 Apr 29 2021
update-ts: 1619712685

So end goal is to get ROS Melodic installed to create some vision packages with Rviz and associated packages. I have successfully done this on ROS Kinetic and need the higher computing power that the 4 offers. Any help would be greatly appreciated

Hi @camri

Thank you for reporting the issue.
We’ll check if we can reproduce the problem with the latest RPi 4B 4GB that we have.
Once it is confirmed, we’ll update the SD card image.
Thank you.

We are facing the same issue.

Any support on this? @willson

I am currently having this issue. Any solution?

Is there an updated image?