Issue with Python Editor in latest TASK V.3.1.4

Just got upgraded to TASK V.3.1.4 today. The ROBOTIS example Python codes load very smoothly now, but my own Python codes will not load. Here are some of my troubleshooting attempts (on a Windows 10 PC):

  1. I tried to save an existing ROBOTIS example Python code under a different file name on my PC, then I could re-load that “saved” example code into the editor OK.

  2. Inside the TASK Python Editor, I could cut and paste my own codes into it, and then saved it under a different file name. But then this file won’t load up into the Python Editor the next time that I used TASK. Using NOTEPAD to pull up both files described in Items 1) and 2) did not show any “funny” character, but it seems that the Python Editor is looking for some kind of specific format of the Python file that it reads in? Or some file permissions?

  3. Once the Python Editor successfully pull up a ROBOTIS example Python code, it will not pull up the second ROBOTIS example code. The editor did not ask about keeping/erasing the previous code. It just spinned for a while, then stayed with the first example code.

Hello @roboteer,
Thanks for your post and for sharing this feedback from the latest update to the software. I’m sorry to hear of the difficulty!

@Tech_Support are there any suggestions we can provide regarding these described behaviors with the R+ Task 3.0 update?

I worked on these issues today, and I can see where the bugs might come from/through:

  1. Whoever worked on this update thought that the user would only need to use the ROBOTIS-provided example Python codes by going through the middle panel found in the Main Menu Screen. So when I choose a new Robotis example code, TASK 3 User Interface correctly asked me about wanting “to close the task file that I was editing” (see picture below)

and then the “new” Python example code pulled up properly.

  1. However if I want to load up (i.e. OPEN) my own MicroPython codes, I would have to go through “Control-O” found on the Right Panel (see picture below), and when I did that, the TASK User Interface NEVER asked me about “closing the task code that I was editing”. So that should help your guys troubleshoot this current update.

Next, the TASK user interface would “spin” for a few seconds, as if it was loading up the new code, but then it gave up and just showed the “previous” code which was not overwritten with the new code (obviously).

For my particular working environment, because I work back and forth between Standard Python (via Thonny) and MicroPython all the time, I do not use the TASK’s Python Editor that much, except to load my own codes (edited with Thonny and saved the normal way via Windows) into the ROBOTIS Editor and then downloaded it to the CM-550. Now that the ROBOTIS Editor does not want to load up my own codes, my work around now is to cut-and-paste the whole program from Thonny into TASK’s editor and then to download that pasted program down to the CM-550. This way, I found that my program worked as normal and the TASK’s editor can still be use as the CONSOLE at run time as normal. So not too much of an inconvenience regarding Python coding for me at this point in time.

1 Like

Hi @roboteer

Thank you for your further troubleshooting and giving some advice.

We are aware of the python example loading bug, and this might be fixed as hotfix,

  • When I performed the troubleshooting, it also seems like the python editor in Task 3.0 has some time-out which functions whether the file is well loaded or not (or maybe be used as error check). So I guess the time out feature would cause the load failure. (Not really sure).

Thank you,

Today, when I use TASK V.3.1.4 in TASK code mode, I found that the user interface does not acknowledge keyboard commands anymore: for example “space” to insert a new line, or Cnt-E to enable/disable an existing line.
Only mouse commands work at present.

Also when using Windows Explorer, tsk3 files are not registered to the TASK 3 app anymore: i.e. when using Windows Explorer to list all TSK3 files, the user cannot double-click on an existing TSK3 file to activate TASK 3 and pull in that TSK3 file at the same time. At present, that action will only open TASK 3 App on an empty TASK3 project.


I see, I additionally report this and try to get it work for the next update.

#1 In task programming windows, Keyboard short key and command are not working (Inserting “Spacing” and “Disabling” )

#2 Listed tsk3 files on Windows Explore does not allow “Double-click” to be activated.

Thank you for your help,

Also, today I found that if my Micro Python code has some errors, the error messages won’t display anymore. I only get the “Compile Error” message but it does not tell which line has the error.

A “new” issue I have found today with the MicroPython API which can be found at (
It looks like that Function “motion.status()” does not work, but using direct-address command such as “etc.read8(68)” does work OK (I am using TASK V.3.1.3).

Also ADJUSTED OFFSET (Address 264 + ID*2) still works as it used to last year in TASK codes, but not in MicroPython codes any more.

I had found on Windows 10 systems, that if you have already installed V. 3.1.4, it will not update to V. 3.1.5 when you tell the App to update itself. You will need to uninstall V. 3.1.4 completely, then reinstall V. 3.0.0 back to your PC. Next this 3.0.0 version will update to 3.1.5 OK via the normal route.