Issues with R+ Play700 Phone app

I am having an issue with the Robotis Play 700 system. When I built the first model, the car, I used the R+ Play 700 app on my Samsung S22 Android phone to control it and it worked well. I then installed R+ Scratch and Scratch 2 as shown in the Play 700 manual. The drivers never ported over when loading the software from the robot car model. I used the shift key in Scratch to load the CM-50 drivers installed when I installed the Scratch software.
That all worked and I was able to program/control the car robot.

I then built the scorpion model and the R+ Play 700 app on my phone no longer works. The blue connect light on the robot lights up but then the screen just turns black with no controls of anything on the screen. Hitting the back button exit to the top picture menu, but none of them work.

I talked to a tech like a month ago and he thought the task code was overwritten. He was gonna send me updated task code and instructions to install it. Never heard anything…
Since then I continue to call with no response.

It has been a long time since I worked on a CM-50 and PLAY700 since I wrote this book “Learning Learning Robotics with ROBOTIS PLAY Systems” back in 2017.

There is also a YouTube playlist that you can check out if you are so inclined:

The issue you posted about gave me the incentive to re-check the materials for my book again, and I found out the problems and a work-around solution for now:

  1. I am using a Samsung S6 Lite tablet on the latest Android update.
  2. The problem I found is with the PLAY700 App as it is installed on my S6 Lite. For some reasons, when the user wants to connect to R+m.TASK so that you can download the example code that came with PLAY700, i.e. PLAY700_TASK_EN.tskx (which is a TASK 2 code). The Android OS is now pulling up the TASK 3 App instead of the TASK 2 App. But then TASK 3 App can’t download this example code to the CM-50 even though it converted this TASK 2 code into an equivalent TASK 3 code. In short, it is like a dog chasing its own tail and going no where!
  1. But I did find a work-around solution for you.

First, I am assuming that you already had installed the TASK 2 Android App on your Samsung S22 OK.

The next step is for you to copy that PLAY700_TASK_EN.tskx file from the PLAY700 App folder to the TASK 2 App folder. If you have a Windows PC, you can just connect your Android device to a USB on the PC using the appropriate cable (probably a USB C cable for the Samsung S22?), and then you’ll see the Internal Storage of your android device via Windows Explorer.

The original file PLAY700_TASK_EN.tskx can be found in this folder:

This PC\ Your Android Device \Internal storage\Android\data\com.robotis.play700\files\Download\RoboPlus\Play700\System\example_01\Task\PLAY700_TASK_EN.tskx

Then, just copy that file onto the PC somewhere, then recopy it back into the TASK 2 App folder on the Android device which is located here:

This PC\ Your Android Device\Internal storage\Android\data\com.robotis.task2\filesRoboPlus

When you get back to your Samsung S22, start the TASK 2 App first and download PLAY700_TASK_EN.tskx to the CM-50 as normal. Then power on the CM-50 by pushing its Start Button the number of times needed to get to your wanted project.

Then switch to the PLAY700 App and make sure to reconnect your Bluetooth device (BT-210 or BT-410) back to the PLAY700 App, then just choose your project and it should work! If not reply to this post then. :grinning: