Manipulator P movements failure

se the following template to help create your post:

  1. What model of servo are you using?
    Open Manipulator P
  2. Describe your control environment. This includes the controller or interface, and any power source.
    Ubunto 18.04, ROS melodic, 24DC, u2d2 (attched to the arm), 1ms latency, 1000000baudrate
  3. Specify the operating mode for applicable models, and any firmware settings you are using.
    ROS MoveIt Joint trajectory controller
  4. Include pictures if possible.

[ERROR] - /omp_control_node: [TxRxResult] Incorrect status packet!
[ERROR] - /omp_control_node: groupSyncRead getdata failed
[ERROR] - /omp_control_node: groupSyncRead getdata failed
[ERROR] - /omp_control_node: groupSyncRead getdata failed
[ INFO] - /move_group_commander_wrappers_1657456265950814301: ABORTED: Solution found but controller failed during execution

5. Include a full description of the issue.

A year ago, we bought a new Open Manipulator P and we have experiment with it since then and everything worked fine up to last week with the same configuration .

Last week, while working with the arm, I started to get fault messages during random movement that occurs at random times , which results in alot of movement failure
I have tried different latency, switching to another U2D2, different USB cable, different PC and non of them worked.