Missing raspi-config for Raspicam to enable it


I am trying to follow the instruction to install the camera for the Raspberry Pi. I am trying to enable the raspicam for my turtlebot. I notice that the only way is to do it through raspi-config; however, it is missing in the Noetic or Melodic image. Does anyone know which version of raspi-config for RP3 B+ with either ROS Noetic or Melodic?

I have a related question about the camera, a necessary element of Autorace2000 functions. The Installation Instructions describe Kinetic repositories, not Noetic. There is no raspi-config functionality in the Ubuntu 20 Command line only Server .Also, can you confirm that the Ubiquity raspicam source scripts will compile in Ubuntu 20.04/ROS Noetic?s

I was able to catkin_make the source from Ubiquity once I follow the steps to source install it. Make sure to change where they mention kinetic to the one you are using (i.e., I use Noetic so I change a line from Kinetic to Noetic). My current error is raspi-config is needed to enable the camera. The Robotis guide seems to have an assumption that we have it, which it does not.

While I have not tried this, the raspberry camera on a Server enabled from the command line by editing your /boot/config.txt file ( on the SD card) and make sure the following lines look like this:

start_x=1 # essential
gpu_mem=128 # at least, or maybe more if you wish
disable_camera_led=1 # optional, if you don’t want the led to glow

1 Like

Following up, I observed there cv_camera node script in the catkin_ws, and there is a raspicam_node launch file in the turtlebotbot3_bringup. What are the correct launch commands to enable the camera and publish camera data?

I resolved this. After RemotePC “roscore”, SBC “rosrun cv_camera cv_camera_node”. Image displayed on RemotePC “rqt_image_view” selecting /cv_camera/image_raw topic. Displayed log: [Info] camera calibration URL: file://home/ubuntu/.ros/camera_info/camera.yaml. Unable to open…not found. How to point to camera.yaml in catkin_ws? Thank you Robotis Will son for including the camera enable in the /boot/firmware/config.txt start_x=1.

Also tried “roslaunch turtelbot3_bringup turtlebot3 turtlebot3_rpi” . Error msg: “No processes to monitor”. Doing a “ros pack find” on the SBC, seems there is no rpicamera node installed-not really necessary since the cv_camera works?

Hi @David_Au
The latest Raspberry Pi recovery image for Noetic includes the opencv library for running the RasPi cam.
You may try installing manually, but in my experience, building the source takes several hours so I’d rather install it with the recovery image.
Just in case you might want to try the opencv installation out of curiousity, you can follow the instruction below (tested with ubuntu 20.04 preinstalled server image for Raspberry pi4)

$ wget -O opencv.zip https://github.com/opencv/opencv/archive/4.5.0.zip
$ wget -O opencv_contrib.zip https://github.com/opencv/opencv_contrib/archive/4.5.0.zip
$ unzip opencv.zip
$ unzip opencv_contrib.zip
$ mv opencv-4.5.0 opencv
$ mv opencv_contrib-4.5.0 opencv_contrib
$ cd opencv
$ mkdir build
$ cd build
$ cd ~/opencv/build
$ make -j4
$ sudo make install
$ sudo ldconfig
$ make clean
$ sudo apt-get update

Turn off Raspberry Pi, take out the microSD card and edit the config.txt in system-boot section.
Add start_x=1 before the enable_uart=1 line.

$ sudo apt install ffmpeg
$ ffmpeg -f video4linux2 -s 640x480 -i /dev/video0 -ss 0:0:2 -frames 1 capture_test.jpg