MX-28 with USB2AX - changing baudrate bricks servo

Hello! I am building a robot arm with five MX-28 servos (firmware versions 39 to 41) and two AX-12 servos. I was prepping them to run controlled by an arduino, which requires setting the baudrate from 1Mb/s to 57.6kb/s. I had previously tested and confirmed each servo working using Dynamixel Wizard 2.0 and a USB2AX dongle, both individually and chained in series. I used the wizard to change the bauds of each of the 7 servos. All but one of the servos took well to the baudrate change.

An MX-28 servo with firmware v39, ID=1, and response delay set to 500us now fails to respond. When I hit “Save”, the servo disconnected and failed to reconnect. The baud was initially set to 1Mb/s, and I tried to change it to 57.6kb/s. I’ve scanned all possible protocols, all possible bauds, and all possible id’s, and the servo fails to connect. When I plug in power, the red light flashes once as expected. I’m assuming that the baudrate was set to some illegal value, but I don’t know if there is any way to recover. I tried the recovery wizard in the Dynamixel Wizard 2.0, but when I unplug and replug the power lead (as directed), nothing happens. Not sure how to proceed, please help!

1 Like


First of all, confirm your cable is not defective.

Second, check your ID is overlapping. (Only one DYNAMIXEL connected to PC when to scan)

If not recovered, communication chip could be defective for some reason, which, in this case, should be sent for repair service to ROBOTIS.