Open rb-150 cant detect ax-12


I have open cm9.04 and recently bought open rb-150
now i cant control my ax-12 using open rb

This is what i did

  1. device manager detect open rb-150 as usb serial device well

  2. This is my device, when i connect cable to ax-12, led is blink well
    (also I can controll this ax-12 in my open cm9.04 and i know that ax-12 id is 1,baudrate is 1mbps)

  3. I uploaded usb_to_dynamixel example in bootloader mode

  4. I searched dynamixel in dynamixel wizard 2.0 and failed

  5. I use scan_dynamixel example and failed

  6. (I heared that scan and ping function bugged now) so I decided to proceed next step, I tried write_ax_mx exmaple, also didnt work.
    I cant use dxl.~ class at all

what can i do next?
I need support.



DYNAMIXEL Controller:

open rb-150 (QC2344)

Software Interface:

window 11 arduino ide 2.3.2

It sounds to me like there may be something wrong with the OpenRB. Do you happen to have another DYNAMIXEL servo that you can use to check and see if the OpenRB can detect it? That will help confirm if the controller itself might be damaged.

If that ends up being the cause of the issue, you can submit an RMA request to your region’s ROBOTIS retailer to have the unit serviced.

When submitting your items for RMA service please be advised: in the event that the units are not covered under warranty you will be responsible for the cost of shipping + repairs (labor/components) before ROBOTIS may return the RMA units.

To proceed with RMA service fill out the the appropriate form from the list above to open a request with your region’s RMA team. In addition, you may find the troubleshooting self-checklist useful to assist in filling out the RMA request form.

1 Like

Thank you for answer.
I did tried 4 ax-12 but it was same.
I think i shoud use as service.
Thank you again.