OPENCR not booting

Use the following template to help create your post:

  1. What model of servo are you using?
    OpenCR board

  2. Describe your control environment. This includes the controller or interface, and any power source.
    CPU: Raspberry pi4
    Controller: OpenCR
    Powersource: PC, given battery, given charger

  3. Specify the operating mode for applicable models, and any firmware settings you are using.
    Default as per e-manual steps

  4. Include a full description of the issue:
    Hi everyone,

I am currently having some issues with my OPENCR board, and I was hoping to get some help troubleshooting the problem. I am using a Raspberry Pi 4 connected to the OPENCR board via the Raspberry Pi’s USB port. Here are the symptoms of the issue:

  1. The OPENCR board does not appear to be booting up properly. The status light on the board is always off unless I reset it, in which case it seems to work okay.
  2. When I try to upload code through the Arduino IDE, I get an error stating that the port could not be found.
  3. I have tried reinstalling the firmware by resetting the board and uploading test scripts via the Arduino IDE. I have also tried reinstalling the software multiple times using the Raspberry Pi.
  4. On the bringup step, I get an error when running “ros2 launch turtlebot3_bringup” stating that “ld08_driver” is not found, even though it is in the home directory.

Based on these symptoms, I suspect that there may be a firmware problem with the OPENCR board, but I haven’t been able to successfully reinstall it. Can anyone offer any suggestions for how to troubleshoot this issue and get my OPENCR board working properly?

  1. I assume that you are attempting to use this OpenCR in a TurtleBot3? In this case, the user LEDs should light up in a cascading rhythm while the OpenCR is on. If this isn’t happening, it’s very likely that the incorrect Arduino sketch is running on the OpenCR.
  2. The recommended method of uploading the TurtleBot3 firmware is detailed in the OpenCR setup section of the TurtleBot3 eManual, just be sure to select the tab corresponding to the version of ROS that you are using.
  3. See 2
  4. ld08_driver is the driver package needed for the LDS-02 lidar unit, and needs to be installed to your ROS system, not just located in your home directory.