OpenRB-150 no longer recognises Dynamixel XM430-W530:

Problem definition:
I can’t find my motor with the Open RB-150 board either via Wizard 2.0 or via Arduino.
I also have access to the U2D2 board with these I have no problem finding the motor.

  • What have I tried:
    I downloaded usb to dynamixel on my OpenRB-150 and then connected directly
    to Wizard 2.0 and also ran the scan_dynamixel script directly after,
    both times without success.

    • USB-C cable would be exchanged
    • different Pc used
    • latest version of Arduino IDE 2.1.0
    • Reset button of the OpenRb-150 pressed
    • Dynamixel LED also lights up red
    • openRB-150 board is only 2 days old
    • the PC recognises board without any problem
  • Weird:
    The OpenRB-150 board is always connected to my PC, and I don’t have any problems
    with disconnection, but as soon as I try to upload something, it disconnects very briefly and
    connects again immediately. I don’t know if this is normal. Maybe the program is not
    uploading correctly, but Arduino does not show me any error message.(see appendix)

  • When did the problem first appear?
    I actually wanted to play my Simulink Matlab program on the OpenRB-150, but since there is
    no Matlab Support Package for OpenRB-150, I selected the Arduino MKR and then uploaded
    my program. As it turns out, this was not a good idea, but I’m surprised that I can’t manage
    to connect the motor to the board.

Look under right. When uploading, the OpenRB-150 board disconnects and connects.

1 Like

In the current D2A library Methods scan and ping do not work properly so don’t use them. But goal position and goal velocity methods worked fine for me.

In Arduino IDE it will switch COM ports as it loads the new program and then switches back to the runtime COM port (that’s normal).

In my Arduino book on Amazon

The free Kindle sample has lots of information on using the OpenRB-150 with Arduino.

First of all, thank you very much for your answer. But nothing happens with the goal position and goal velocity scripts either. What I also noticed is that the motor even flashes red briefly when I switch on the board. In any case, it’s very strange that I can’t manage to find it.

All right, then this can’t be the fault that the board disconnects and reconnects.

When you power on the motor, its LED is supposed to turn on briefly then off. So that is a good sign.

Did you install the correct board and the D2A library as shown in my book sample into the Arduino IDE. If so things should have worked.

What is its QA number on the sticker in the back of the board? Does it feel “warm” near near the USB and MOSFET areas after you used it?

I have followed the instructions from ROBITIS to install the D2A library. OpenRB-150 emanual
I have uninstalled and then reinstalled the D2A library several times. I have also tried different computers and versions of the Arduino IDE to solve the problem.

The QC number of my board is 2234.
The board is one week old.
Everything worked for the first 2 days until I tried to load my Simulink code onto the board using the Arduino MKR support package. Since then, there has been no communication between the board and the motor, although both components seem to be working fine.

The board does not warm up.

1 Like

It looked like Simulink messed up the board firmware somehow. As an end user I had not encountered such a situation you need to contact Robotis directly @Jonathon can help better

All right, thanks anyway for your help and time.

Double pressing the reset button on the OpenRB-150, it will start in bootloader mode.

Reuploading the USB2DYNAMIXEL for the OpenRB-150 from bootloader mode should restore functionality if this issue was caused by uploading the wrong board firmware to the unit.

As soon as I double press the reset button, the board changes the COM number when uploading and it aborts. (See attachment) Do you have any idea how I could solve this problem?

Look under right.
bootloader mode

In this video are you entering bootloader mode on the OpenRB (double pressing the reset button until the yellow light begins to flash) before initiating the upload? It is normal for the board to appear as a separate port in bootloader mode, but you should enter the mode and select the port before starting the reset.

I think I have executed the bootloader mode correctly, but I have recorded a video with the mobile phone to check. I hope you can see everything in the video.

Unfortunately, the file is too large, so you will have to watch the video via this link:

From my experience with using Arduino IDE 2 that default Port Setting may not be current enough. Please drill down that sub menu and choose the current port after you switch to boot loader mode.

I think I did it in the video the way you suggested.
In sec (1-10) you can see that I switch to bootload mode. After that, the board has no connection with the computer (see sec. 13). Then I open the sub menu and manually assign the COM number (sec. 20). After that the connection is stable, i.e. the COM number does not change any more. Then I click on upload (sec 23) and the COM number changes during upload, but I cannot change the COM number manually so quickly during upload.

If I have misunderstood your suggestion, I am sorry.

Below are the results of my tests with my OpenRB-150 (QC code is also 2234), regarding the sketch usb_to_dynamixel:

  • Normally my Windows11 PC sees this OpenRB-150 as COM6, and I can download this sketch fine and then use Dynamixel Wizard 2 on it fine.


  • When I put my 150 into Boot Loader mode, my PC sees it connected to COM13

and I can download this sketch also fine via COM13. However I did not see the kind of output messages shown below in your MP4 file - although they are shown on mine. Note the last two messages shown below.

Maybe you should uninstall your Arduino IDE completely and make sure that you delete the ARDUINO folder under your "Documents’ folder too, and then re-install the latest ARDUINO IDE 2.1.1 and reinstall the 150 board and D2A library to see if all that helps. If not, it may be time to get a new OpenRB-150.

Thank you again for all your ideas and suggestions. I am confident that many others who have a similar problem will find a solution here. Although unfortunately my specific problem could not be solved. But my new OpenRB-150 board arrived today and is working fine.

I suspect that the problem is firmware related and I am confident that I could solve it if the bootloader mode worked. If I find a solution to this problem, I will definitely post it here.

Ask Robotis to see if they are interested in getting the old 150 back. They have more resources than end users to figure out the possible issues.

Another thought. Can you use Windows Device Manager and remove all the hidden COM ports associated with the old 150 and then plug the old 150 in again to the PC? Maybe a fresh COM driver install will clear the issues with the old 150?

It is a good consideration to contact Robotis. Where would be the best place to contact? I am located in Germany.

Maybe I will give it a try at the weekend, but unfortunately I have doubts that this will help. After the problem occurred, I also tried the board on other PCs that never had an OpenRB-150 board connected to them before, and still the problem occurred again.

For contact with Robotis to do RMA @Jonathon is your best contact. Do you want it fixed or just returned to Robotis for investigation?

See this post for different RMA options

It would be enough for me if someone would take a look at it. It seems that the board works fine, but the motors are not recognised. I think it would be a shame if it just sat in your drawer without being used. I think it’s no problem for a professional to solve the problem and I would also like to know what the exact problem is and how it can be solved.

Small update: It turns out that the problem was not related to me trying to upload a Simulink code because the new board is not working today either. Yesterday everything ran smoothly and I only used the Arduino IDE. Today the board no longer recognises the motor, although everything else works just as well as with the old board.
I have no idea what I’m doing wrong.
Since I don’t want to buy an OpenRB-150 for the third time, would you perhaps know what alternative I could consider instead?

1 Like