Problems with the DYNAMIXEL XL330-M288-T turning off


I bought the 16 DYNAMIXEL XL330-M288-T to make the LEAP-Hand robot.
I control this robot using one U2D2 and 5V Power Supply.

On some power supplies, this works fine, but on others, the motor lights up red and shuts off when current is applied.

DYNAMIXEL Wizard doesn’t care which power supply I use.

I tried reducing the PD gain on a power supply where the motor kept turning off, but it didn’t turn off and it worked.

But in situations where the torque needs to grow, it turns off again.

It’s probably an issue with the current. But I don’t know the exact problem.

The cheapest power supply was the one that didn’t have any problems with motors shutting off at all.

I think it’s current limiting, but I don’t know if it’s a motor issue or a power supply issue.

I would appreciate it if you could let me know where the problem is occurring and what I can do to fix it.



DYNAMIXEL Controller:

U2d2, Dynamixel SDK

Software Interface:

I use the PYTHON to control the robot

Reading the Hardware Error Status register on your DYNAMIXEL servo will give you information on the specific error that you’re encountering so you can figure out why only some of your power supplies are causing the issue.