Question about BT-410 controller

I’m trying to control RC-100b using Bluetooth module Bt-410 and the controller is CM-530. But I’m not sure if the channel setting is wrong, but it says it’s connected but it’s not working. Anyone know about this please help.

You will need a matching set of BT-410s Master & Slave. And there is no channel to be set.

We already put the master on the controller and we put the slave on the controller. But it didn’t work nonetheless. When it worked as a virtual remote, it didn’t seem to be a program issue.

When I used TASK 3 to look at the Demo files for the Bioloid GP (TASK and MOTION), I can see that there are 5 instances where Parameter GyroMode is set to TRUE (see picture below) in the TASK program:


Please change all of them to FALSE and see if that helps.

For the MOTION file, it looks like that the DXLs are already set to AX-12s, so should not be any problem for MOTION.

Also as far as Remote Control via BT-410 (or any other BT) there is no issue in the demo TASK file. The BT-410s (Master & Slave) should have their blue LED lit up solid.

So please try those changes to the TASK program and see.

I’m not using a gyro sensor. The task file has never really done the gyro sensor. Also, it says that the master and slave are connected without blinking, but it doesn’t work when I press the pilot. Sorry for being a beginner. Please explain in detail…

Are you using the ROBOTIS demo TASK and MOTION files? Or are you creating your own TASK and MOTION files?

I create my own task and motion files

In that case, have you checked your robot using the ROBOTIS Demo TASK and MOTION files? If your robot works with ROBOTIS files using the 5 changes I mentioned previously, then you can start investigating what is the difference between ROBOTIS codes and yours. If your robot does not work with ROBOTIS code, then we can try other troubleshooting approaches. You have done firmware recovery on the CM-530 right? Just in case it got corrupted somehow.

Can you share your TASK and MOTION files?

Firmware recovery has been completed and the task file and motion file have not been completed yet. As I said before, I was unable to create a motion file because it moved strangely when reading motion. I will use the example as your advice and let you know the result. Thank you.

Yes we need a reference point before we can go forward

We tried RoBotis demo task and motion files. But It didn’t work. also, we read motions. but it worked strangly like this video. Can you solve this problem?

I think that I have seen this kind of weird behaviors before as I did them in the past myself, when I was not careful about not setting ALL my servos to the 512 position (basically align the notches on the horn and servo body) before assembling them into the various frames.


But now that you have already assembled the arm, one “least-painful” procedure is as follows:

  1. Unscrew completely the 4 screws that fasten the horn to the frame parts so that the horn is completely “decoupled” from the frame parts. But keep the big screw on the back side in place (the one that goes through the motor axle). In this way, most the arm structure is still in place so it does not fall apart during the next step.

  2. Next, use Manager tool so that you can put the servos into the 512 position. Now the horns will move to this position without taking the frame parts with them (i.e. the arm does not get into the previous crazy positions). Then check to make sure that the notch on the horn matches with the notch of the servo body. This step verifies that all your servos can go the 512 position properly. If some servos do not do this operation properly, you may have to recover its firmware on each faulty servo by itself next before going on Step 3.

  3. Now choose a Motion that you know will put the arm is a “KNOWN” physical position (using the Motion tool or Manager tool), of course the servos will then move to those positions (without moving the frame parts).

  4. Then manually start moving various frame parts to their “KNOWN” physical position for this Motion Page (you can do this one frame part at a time). When the frame part “reaches” the “correct” position, then put the 4 mounting screws back into the servos horn at this location. This step verifies that the servos can go properly to their “programmed” positions with the frame parts fastened to the servos.

From then on, you should not get crazy motions any more, when you are using the Motion tool on your robot.

Thank you. Thanks to you, I solved the weird motion at 512 degrees. But I couldn’t solve Bluetooth. I couldn’t control it with RC-100B even if I used the example as it was. Also, I tried it on my mobile, but there was no difference. Do you know anything? Please give me a quick response.

RC100_Music.tsk3 (2.1 KB)

Please try the above TASK 3 code and see. I have verified it on my own CM-530.

Also try to use the Virtual Controller from inside TASK 3 via the USB Cable. See picture below:


If the Virtual Controller works for you, this means that your RC-100b has gone bad or the BT/UART port on your CM-530 has gone bad (unlikely though). Your Master and Slave BT-410s connect to each other OK right? Their Blue LEDs stay solid after initial connection right?

It worked with a virtual remote. But it doesn’t work with the Rc-100B. I don’t understand. I tried it with different rc-100b and kept switching to another BT-410

It sounds more like the issue is with the Master or Slave BT-410 modules then. You may have to use Terminal tool to get deeper into their firmware to check.

Can you access a USB BT-410 dongle? Then it should automatically connect to any BT-410 slave from the PC. This way we can check the Slave module just by itself.

Or can you just buy a new RC-300 from ROBOTIS?