Recovering servos on Mac with USB-C to USB-A converter?

I am using three XM430-W350 servos plus one XL430-W250-T. I unfortunately set them to 3MBaud and cannot talk to them using my Arduino Mkr plus Dynamixel Shield anymore, so I ordered an U2D2 and power board, to be able to get them to work again. However scanning does not recognize them, and I have been able to recover one using the Recovery function after many many many attempts. I think this is due to me being on Mac, which only has USB-C ports, and using Apple’s USB-C to USB-A converter.

I have also tried a Dell USB-C to USB-A converter, a USB-C hub with USB-A ports, and a USB-C to MicroUSB cable; none of these even recognize switching power on the servos on. With the Apple converter, this works and it tries to flash, but reports “Flashing failed” all the time.

I know that the servos themselves power on because the LED switches on. Sometimes it stays on during and after the flashing process. Sometimes it does not switch on when I turn the power on, but after a couple of flashing attempts this usually works.

As a power source I am using a bench power supply, with 12V (have also tried a bit higher, up to 14V).


Here’s my own answer: I’ve managed to reset all servos, and install the newest firmware on all of them, using a Windows PC. This is not the first time I had trouble with USB-C to USB-A conversion on the newer Macs; e.g. flashing certain Arduinos is not too reliable, but it works 60-80% of the time. With U2D2 it doesn’t work at all. Not recommended.

Unfortunately, these issues on newer Apple Silicon Macs are unavoidable.

Apple has limited the ability of 3rd party drivers to make the types of low level changes required for reliable USB serial communication, so the FTDI drivers required for proper function of the U2D2 don’t work correctly on these new macs.

We have reached out to FTDI regarding this issue and they have confirmed that they are in communication with Apple regarding this issue, and will update their drivers as soon as possible, but unfortunately they have not provided us with an expected timeline.