ROBOTIS MINI will connect via bluetooth and connect to R+Motion but not sync position with R+ Motion

Edutainment Product

Robotis MINI eng (No Head Servo)

Issue Description

I am able to connect to the robot via bluetooth, and then connect to it via R+Motion, but not sync the position data from R+Motion to the robot. I have tried swapping the bluetooth board and the main board out with no change. I have checked to see if all cables are correctly plugged main board. I tried using the firmware update tool through RoboPlus, but I when I follow the instructions and try to connect to the same port R+Motion uses for this robot it errors out either sayings nothing is connected or to restart the tool.

Additional Information/Attachments

Seen here it does not register any joints.

That is very odd.

I just tried my MINI on MOTION 2 and MOTION 3 (via TASK 3) and they both worked fine. I am using BT-210. Which BT device are you using? BT-210 or BT-410? And are you using a Windows PC? Which OS version?

Have you tried to connect via USB also?


The manual specifies BT-210. I am on a windows PC running Win 10 Version 10.0.19045 Build 19045

And I have tried connecting via USB as instructed in the firmware update instructions: ROBOTIS MINI

Were you able to recover the firmware of the OpenCM-904 via USB?
And you have built the complete robot and connect the XL-320s to the OpenCM-904 Controller?

That is when I could not connect to port 22, the port used with R+ Motion. It either said no device was on any port or to restart the software.

I have built the complete robot and connected the servos, I checked to make sure they were connected correctly. Even if they weren’t, would it not just flip which servos respond to which commands? It shouldn’t completely interrupt a sync I would think, but I am new to all of this.

By 22, you meant COM22 right?

You can only use ONE App at a time that uses COM22 (this is a Windows requirement). So either MANAGER only, or RTASK only. Windows won’t let you connect two Apps to the same COM port.

Correct, COM22. I noticed this, so I disconnected R+ Motion and tried with just Task. I am not with the robot at this moment, but I will send a picture hopefully soon with these errors in Task, outlining my process.

For now, you need to concentrate on Recovering the Firmware on the OpenCM-904 ONLY using USB cable first.

When MANAGER connects to your bot, does MANAGER Window look like this

In particular, does the value for “Dynamixel Channel” equal to “0”?

When connecting I am given this page:

To try and recover firmware I proceed to that option following these instructions:

It is here I am unable to connect to my robot. I have no other R+ software open, nor am I connected to bluetooth. Each option fails with varying errors:

Errors include:

Update: I restarted the software and connected to port 11.

I recovered firmware and then accessed Update and Test:

After recovering firmware and resetting factory settings I exited Manager and reconnected via bluetooth to R+ Task 3.0.
I then connected successfully and went to sync it, and it still registers 0 Joints :frowning:

@lucdbast - Good that you are making progress!

Your Manager’s screen should have listed all your XL-320s (see my post). But on yours, the XL-320s are not listed.

So, I think that the remaining issue is that all your XL-320s may be still set at 57.6 Kbps (factory default value) and right now you got your OpenCM-904 communicating to them at 1 Mbps (i.e. Address 12 “Baud Rate (Bus)” is currently set to 3) - i.e. the controller and the DXLs are not talking to each other at the same communication rate.

Thus can you get back and use Manager to connect to the OpenCM-904 + DXLs again, and change the value of Address 12 to 1 (i.e. to 57.6 Kbps) - see picture below.

Then the MANAGER tool will take some time to readjust to the new comm. rate of 57.6 Kbps and hopefully you will see all your DXLs inside Manager then!

You should also check this free Kindle excerpt from my MINI book, and there are all kinds of hardware information in it

In particular, see if you can make yourself a USB slot as shown below. It will be handy to troubleshoot your robot via USB cable without having to dismantle your MINI every time, like you probably did a few times already.

Your robot will also be ready to use with Arduino, if you ever want to go that way in the future.