SBC wifi problem with Melodic

I have confiured network as described in 3.2.3 Configure the Raspberry Pi (MELODIC).
Wifi configuration works only once. After rebooting SBC is not connecting WIFI again.
Configuration is file /etc/netplan/50-cloud-init.yaml seems to be ignored.
Problem stays even when I write network: {config: disabled} file to /etc/cloud/cloud.cfg/99-disable-network-config.cfg.

Thanks for advice

Hi @Udo_Michelfelder
I’ll share the Melodic recovery image for RPi 3B+ with you.
Preparing the image will take a couple (working) days.
In the meantime, could you check if you have any other file in the netplan directory that could override the network setting?
Also, in some cases, setting a country code for wifi could help resolving the issue.

Hello Will,

my linux skills are limited, so I am not shure if I can help you much in this regard.
Just for your information I discovered a similar problem when I was trying to upgrade my Jackal (Clearpath) from Kinetic to Melodic (i386 PC).
For now my solution on the Jackal is using a Jetson Nano, here it was no problem to get Melodic up and running.
For my TB3 waffle with openmanipulator I will stay with Kinetic til Melodic gets supported for both TB3 and openmanipulator. ROS2 would be an option too.
Do you have any plans to support Jetson Nano with TB3 waffle? I would like to use a 3D cam such as the ZED2 or OAKD and think that Jetson Nano would be a advantage.

Best Regards


I understood. Hopefully sharing the recovery image will relieve agony in SBC setup procedure.
We do have plans for upgrading TurtleBot3, but I cannot disclose further information at this time.
But I can say that it will be beneficial to many ROS users as well as TurtleBot3 customers.

Hello Will,

I have same problem with Udo_Michelfelder.
Wifi works only one. After I reboot the system, wlan0 is going offline. It seems like config.yaml file is being ignored.
Did you prepare the image for RPi 3B+?
I need that image to try. Or do you have any other solution for wifi issue? Because I am stucked.

Thanks or your help.
Baran Deniz DOĞAN

Hi @barandenizdogan
Depending on Ubuntu version, some may have an issue with supporting RPi hardware devices
Please try below image that I tested.

  1. Download the image file.
  2. Extracting the file and burn the img file to microSD card. I used disks utility in Ubuntu.
  3. Connect monitor & keyboard to RPI3B+.
  4. Turn on RPi and login with ID : ubuntu , Password : turtlebot
  5. Replace your WIFI_SSID and WIFI_PASSWORD to 50-cloud-init.yaml file using below command.
$ sudo nano /etc/netplan/50-cloud-init.yaml
  1. Save the change and reboot
$ sudo reboot
  1. If your platform is TurtleBot3 Waffle Pi, please modify the ~/.bashrc as below where TURTLEBOT3_MODEL is defined.
export TURTLEBOT3_MODEL=waffle_pi

Thanks for your help. I will try and reply soon.

Hello again Will.
I just tried new image file melodic.
At the begining It works but when I do apt-get update&upgrade, wlan0 goes down and unable to connect internet. I cant figure it out to connect internet as well. Did you try update&upgrade on Pi?

Hi @barandenizdogan

Thanks for reporting the issue and confirmed that happens after apt update && upgrade.
This resolution has been tested, but still requires an ethernet connection in order to download the firmware files.

I’ll make sure to include these in the revised version of recovery image.

$ wget
$ wget
$ wget 
$ sudo cp *sdio* /lib/firmware/brcm/
$ sudo reboot

It says “Use dpkg-divert to stop these files being overwritten on package updates.”.
I cannot figure it out what should I do. Is that necessary to do that ? If its necessary, how can I do ?

Have you tried the commands that I wrote in the above reply?

Yes. I did. But same problem. There is another code line. “Use dpkg-divert to stop these files being overwritten on package updates.” Maybe that will be the solution but I cant use dpkg-divert. Can you help me for that?

The files should have been overwritten as intended.
Didn’t rebooting RPi detect the wlan0?

No, RPi is still offline. I think This files shoul be permanent. The upgrade have been overwrite these file.

I can’t reproduce your issue with mine.
I’ll create another recovery image for you and see if it works.
I’ll be back soon, hang in there!

Try this image that I upgraded to 18.04.5 and tested with my WiFi.
TurtleBot3 RPi3B+ Melodic test image