Strange level voltage on TTL with arduino shield


Hi, it’s my first time with Dynamixel servos and I try to drive them with the arduino shield. I use an AX-12A servo and I have no replacement part.
I followed all startup guide but nothing is detected by the scan exemple provide by the arduino library.
When I use the U2D2 with Dynamixel Wizard, all it’s OK at 1000000 bps and I have the following frame :
But when I use the arduino shield the frame was very weird :
I tried to use different power supply or switch between arduino or external power but nothing happened.
On the frame we can observe than the rest state is near 0V and the high level voltage is 3.5V for the sent message and only 2V for the response.
Anyone have an idea to solve this issue ?
Thanks for your response.

arduino wiring :



DYNAMIXEL Controller:
Arduino shield and U2D2

Software Interface:

Dynamixel Wizard 2.0

First that scan sketch in Arduino has never worked for me. Ping also. So try to use Goal Position or Goal Velocity to see if your dxl is working or not.

TTL signal must keep high level(5V) at nomal state.
Please check the pinmap, specially GND and TTL signal.


Polarity checked twice before posting, I also change the arduino board.
I tried to disconnect the shield and use only pins needed but I don’t have the schematic for do this correctly.
If I observe finely the frames, I can see than the useful data is correctly transmitted but the voltage level are not good.