Trouble Finding Port for OpenCM9.04+OpenCM485EXP


I am trying to set up my computer (MSI GS66 Stealth Laptop, Windows 10 version 20H2, 64 bit) for Dynamixel SDK and/or Workbench in order to run an OpenCM9.04 mounted on an OpenCM485EXP, which will run 5 Dynamixel AX12a servos and read 6 analog input signals. Boards/servos will be powered by an SMPS 12V 5A power supply.

In trying to follow these instructions, I attempted to install ROS2 Foxy. I also configured my Arduino IDE for OpenCM9.04.

However, I have not been able to have either Roboplus 1.0 or Arduino IDE recognize the port when the OpenCM9.04 connects to the laptop through Micro USB-B. I tried installing the latest VCP driver from FTDI, installed this driver, installed the USB CDC driver .inf file from the Roboplus file I downloaded, but still, neither Roboplus 1.0 nor Arduino IDE recognize the port, and no port driver appears in the Device Manager.

Any help would be appreciated.

Thank you.

1 Like

Hi @Ethan_727, thanks for your post and welcome to our page!

Regarding your question, have you had the opportunity to try connecting to the OpenCM9.04 with “R+ Manager 2.0” software? Currently, the “2.0” version of the manager software is our most up-to-date for the OpenCM9.04 and this might help. R+ Manager 2.0 can be downloaded from our software page

Can you let me know if that software is able to connect successfully?

As a second initial suggestion, have you had the opportunity to try connecting using a second USB cord, and different USB port on the computer?

1 Like

Thank you,

Originally I did not download R+ 2.0 because it seemed AX12A servos were not supported.

I have downloaded and installed R+ Manager 2.0, opened it, selected OpenCM9.04, and went to the Update and Test section. When trying this, I received the error “The port does not exist.” I tried 3 different USB ports on my laptop with the same result. However, I do not currently have a second USB cable. The one I am currently using does power the OpenCM9.04 board, as indicated by the LED, but for some reason the port is not registering.

Hello @Ethan_727,

Thank you for your response, and for sharing the results of downloading the software. Typically, the Windows OS should include the needed drivers or the software should provide them. I believe the OpenCM9.04 connects using STM32 drivers for Windows.

Are you able to observe the OpenCM9.04 in the Device Manager of your computer? If so, can you share what it is currently labeled as, and what section it’s listed under? If detected correctly, it should be detectable under “Ports: COM & LPT” as “ROBOTIS Virtual COM Port”.

While it’s not clear why it’s not detected using the built-in drivers in Windows, it might help to download a current version of STM32 drivers here:

Based on your responses, either myself or @Tech_Support can suggest additional troubleshooting.

1 Like