Trouble with using in Pycharm

Hi everyone, I’m new to programming: I’m a mechanical engineer in school currently. I’m having to create a robotic arm for my internship and I’m using the Dynamixel XM540-W270-T and XM430-W350-T servos. I can get the servos to move using the Dynamixel Wizard, but I’m trying to test them with the code in PyCharm. I’ve also tried testing the C++ code in Visual Studio 2015. I’m having two different errors I don’t know how to solve. In PyCharm I get this error:

And in Visual Studio I run the code and it continually posts this:

Can anyone provide any input? I’m completely lost. Sorry for my lack of background with programming.

Hi, did you successfully setup the library environment in Visual Studio?

Please also refer to Python library setup guide. (Unfortunately, we’ve written this instruction with Atom IDE instead of PyCharm)

Which communication interface are you using to connect DYNAMIXEL and your PC?
U2D2(officially supported) will provide the most stable environment, but some users use their own interface to communicate with DYNAMIXEL.