U2D2 connection with windows

I used to connect two Dynamixel motors (XC430-W240) with a U2D2 unit with the power hub board to my computer (running Windows 10) normally without issues. Suddenly, U2D2 does not even appear neither on the USB ports nor on the universal bus serial controller on my computer. But the red light on the U2D2 still turns on. I tried to connect U2D2 to another PC, then it connected properly(and tested using DYNAMIXEL wizard).

However, my computer still does not recognize U2D2 device. Here’s what I’ve tried so far:

• Following the instructions here: How to Find the ROBOTIS U2D2 Connection in Windows (Troubleshooting / Driver Tutorial) - Quick Start - ROBOTIS (my U2D2 does not even show up as a USB Serial Converter)
• Replacing the USB cable.
• Plugging in and supplying power to a Dynamixel.
Nothing worked. I would really appreciate your support.


There may be a good chance that your USB Device Manager info got scrambled recently. So you will have to un-install this U2D2 Device from the Windows Device Manager tool, except now it is hidden from the user!

Hopefully you still remember the COM Port you used to access your U2D2 module - you will need this information in the next steps:

  1. Download ZIP file and install the DeviceCleanup tool from this web link:
  1. Next, make sure that your U2D2 is DISCONNECTED from your PC. Then you need to run DeviceCleanup.exe at ADMINISTRATOR level.

  2. This tool will show you the “non-present” USB devices on your PC. Hopefully, your U2D2 device will still be in this list. For example, my U2D2 module was associated to COM15 the last time I used it - see picture below


You can see that a “USB Serial Port” item and a “USB Serial Converter” item are listed one after the other - the last time I was (or you were) able to use them. Just delete these 2 items on this list and then reboot your PC.

  1. After your PC successfully gets back into Windows OS, then plug your U2D2 module back in, and then Windows OS should be able to “detect” it as “it was for the the first time”, and next it should install the correct drivers for it (which in theory your PC still has them!). And you would/should be able to use your U2D2 again.

Good Luck!

Hello dear,
Thank you so much for helping me out. Fortunately, I remember the port name(COM5). Then I did the same steps as you explained. But it didn’t work. here is a screenshot from DeviceCleanup and DeviceManager after doing the previous steps:


Did your Device Cleaner show those two FTDI devices (like on my PC) before you erased them? You did reboot the whole PC and then re-plugged in the U2D2,right?

At present, can you go to Device Manager and click on VIEW and then enable Hidden Devices and take a screenshot for me.

That device “libusbK” is the one bothering me - as I have never seen such a device associated to a U2D2 device. Is this a genuine U2D2 module from ROBOTIS? If it is, it should have a “legitimate” FTDI signature as shown in my screenshot.

You can install DeviceCleaner on the PC that worked with the U2D2 and compare settings and maybe figure out things yourself? I don’t have any other suggestion at this time.

Hello again dear,

Actually, the device was appearing all the time but with a different name. I installed a driver for another device and somehow it changed U2D2’s driver. Then I changed the driver and everything worked properly. Thank you so much for helping me out.

Also you need to remove that “Unknown USB device” with Descriptor Failure which serves no purpose anymore.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.