Updating Firmware for RPi0-2W/Pi Camera module used with CM-550

Hello @Tech_Support,

I have my own RPi0-2W with Pi Camera (see setup shown below - using BT-410 USB dongle between PC and CM-550):

I used the instructions shown at this link to prepare a new SD Card for a V.2 image, i.e., the recovery procedure.

Everything worked out fine. I hooked my RPi02W to the CM-550 and booted both up into Manager 2 which recognized both of them fine (see picture below):

You can see that Manager says that the RPi02W needs a new firmware, but Manager won’t let me update this firmware to V. 1, unless I used a micro-USB cable/port. But the only USB port on the CM-550 is already “used up” by the RPi02W!

So, I had to choose “Update Later”. You can see in the picture below that Manager can access the Control Tables of CM-550 and RPi02W OK. Note that the “Image Version” is 2.

I have tried to set the RPi02W to track a Red object and it did it fine.


The only issue that I need help on is how to update the RPi02W’s firmware to V. 1. I had tried to use the LN-101 to access the CM-550 via its UART, but MANAGER won’t let me update firmware via LN-101.

Afterwards, I have also tried to go the route via the DXL.RTS file (i.e., the RPi Update process), but I got stuck at the step when I need to get on \\raspberry.local. When the network asked me to enter the password for the user “pi”, I entered “robotis0” as mentioned on the e-manual, but then it said that this was not the right password.

My Windows 10 PC did connect to the WiFi RPi network OK prior to this step - using the same password “robotis0”.

Does it have to be an actual RPi02W from ROBOTIS for all this to work?

Thank you.