Windows Does Not See U2D2

Hello,

I recently purchased two Dynamixel motors (XC330-M288-T) and a U2D2 unit with the power hub board. I’ve been having trouble connecting the U2D2 to my computer (running Windows 11). When I plug the board into my computer using the supplied USB cable, a red light on the U2D2 turns on. However, my computer does not recognize the device. Here’s what I’ve tried so far:

• Following the instructions here: How to Find the ROBOTIS U2D2 Connection in Windows (Troubleshooting / Driver Tutorial) (my U2D2 does not even show up as a USB Serial Converter)
• Replacing the USB cable.
• Plugging in and supplying power to a Dynamixel.

Nothing seems to work. I would really appreciate your support.

Thanks.

1 Like

Update: I got a Linux computer running Ubuntu 20.04, and things seem to work now. Not sure why my Windows computer wouldn’t even acknowledge me plugging in the U2D2.

1 Like

Well. it’s bit strange. Are you using USB multi hub board? One of hub USB board (3p) of mine fail to detect FTDI driver chip when connected but the others are okay. So, it is worthy of changing the port connecting !

No multihub… I’ve tried both my USB A ports which work normally and nothing.

Try install FTDI Windows Driver. - Connect to your PC Mainboard’s USB (not case front panel) / Laptop without USB-Hub

Look at Device Manager, Is this recognized in USB? Ports?