X Series Electrical Shock Error Question

Hello I have XL430-W250 * 1 ( Extended Position Control Mode )

Put the DYNAMIXEL in the base
and turning the white turntable ( 3 - 5 kg )

The DYNAMIXEL show Electrical Shock Error when using DYNAMIXEL when non stop work up to 60hrs.

After the error, it can find servo info in Wizard2.0 and also can recovery (communication chip still work).

Can torque on but can not turning DYNAMIXEL ( show ES error again ).

I’m sure input voltage is 12V/5A, I didn’t know how this error happened.
ES error

Update XL working video

Hi @Doubian

I’m sorry about the delayed response.

When the electrical shock error occurs during a long time operation, please check if there’re any operating conditions are exceeding the specifications of DYNAMIXEL.

For example,

  1. Check the operating voltage. Due to the excessive acceleration and deceleration or external load may cause fluctuation of the input voltage of the DYNAMIXEL. Please make sure that the supplying voltage is stable during the operation.

  2. If possible, try reducing the external load that is attached to the DYNAMIXEL, or allow longer pause time between each operation to reduce the load over a time period.

  3. In case of the distinctive temperature rise during the operation, please apply cooling for the DYNAMIXEL.

Thank you.

Very useful information, thank you @willson

I will check DYNAMIXEL feedback data ( vol, load, tmp ).

I already restore DYNAMIXEL using weird way.

If DYNAMIXEL happened this error next time, has any suggestion to restore DYNAMIXEL ?

I tried,

  1. Recovery
           error not restore, DYNAMIXEL not working.

  2. Factory reset in Wizard2.0
           error not restore, DYNAMIXEL not working.

  3. Weird way
           pick up gear and place again ( the same gear ), it's solved, DYNAMIXEL work.

Thank you.

Hmm… that is weird…
Does the turntable easily pick up the static electricity?
I’m wondering if the DYNAMIXEL exposed to static environment as it seems there are many plastic parts rotating.

Yes, almost plastic parts like PP TPU.

I’m still not quite sure what causes the ES error, but if picking up and installing it again works, it could be the electric static.
How long time did you spent between picking up and reinstalling DYNAMIXEL?

Very quickly, less than 5s, and DYNAMIXEL wasn’t happeded error again.
Maybe is electric static cause error.
I will changing turntable’s material and testing again.

Very thank you :slight_smile: