Bioloid premium robot software

Use the following template to help create your post:

  1. State the model of servo you are using.
    AX-12 servos To whom it may concern I would like to know why when I press the play button on the back of the robot it stands, hit top button on the cm530 my bot does a split. The upper body everything is ok, but not the bottom and everything is fixed right. So, please help me out thank you, Jerseylance.

  2. Add (or create) Tags to your post with the specific model of your product.

  3. Describe your control environment. This includes the controller or interface, computer and OS, and any power source you are using

  4. Specify the operating mode you are using, for applicable models.

  5. Specify and link any manuals or resources you have used related to your inquiry.

  6. Include pictures if possible. This can help our members see how wires are connected, how hardware is installed, or to identify other possible issues.

You can first try to lay the robot on its back (to take out the effect of gravity of the upper body upon the lower parts) and use the Manager tool to check if all servos are “connected” together. Maybe some wires were getting loose. When a loose connection is present, all other servos down the line will loose connections with the Controller also.

If they all “showed up”, then run your program while the robot is still on its back. Hopefully, the legs are now moving as “programmed”? If this turns out “positive”, you can then put the robot back to its standing position and try again with your program. Maybe, all would be OK then?

When in standing form, the wires would tend to fall or get caught between frames and servos (so check for these issues too), and when the servos move, all you need is a momentary loss of connection to mess up the execution of your Motion Pages.

Thank you for responding back, but when I press the play button I hear the right tune then the bot does a split trying to walk but no prevail.

After it does the split, can you use Manager then to see if all servos are still recognized? And can you move them a little bit just to check?

I’m going to send you a video of what I’m saying ok.

It looks like that your humanoid robot uses 20 servos? and you also have lights and other sensors working. So how are you powering all this? You probably need two separate power supplies one just for moving the bot and one for all the other stuff. Make sure that they share a common ground and dxl data lines if you are using only one CM-530 controller.

1 Like

Good afternoon, and those sensors are from robotis to use with the cm530.

Good afternoon sir, question is it possible to use 2 different servos on the bioloid for example 2xl430-w250-t with the AX-12 servos. All I would need is 2 of the 2xl430 for more flexibility please let me know thank you, Mike.

Unfortunately CM-530 can only handle Protocol 1 (AX-12) and CM-550 only handles Protocol 2 (2XL-430). One possibility is to additionally use OpenCM-904 to ONLY control 2XL-430 or two smaller XL-330s for the head - use 3M Dual Lock tape or strong dual sided tape to fasten them together. Essentially you have 2 independent Dynamixel Networks that can share Remocon packets via the 4-pins UART ports. But then you just lost RC capabilities as you just used up the standard 4-pin ports on the CM-530 and the Open-CM 904. If you still need a second UART port for RC commands through the Open-CM 904, you’ll have to think about using the OpenCM 904 in Arduino mode to access its Serial3 port. How are your skills in C/C++ programming?

Good morning, I’m sorry to bother you but I have 2 cm530 controllers both I’ve received I believe last year or 2020. One of the controller was rebuilt by you guys, and the other I purchased brand new. The rebuilt one is working, but it’s problem is with the power from the battery which it won’t turn on unless I use the power cord. The new one problem is when I connect all the wires up, and press the play button my robot does a split, and I’ve downloaded the programs from the motion editor and R+plus task, but it does a split so please help me out so I can teach this to my summer class thank you, Mike….

I ran out of ideas of what might be the problems that you encountered. If the old controller works for you along with the use of the power cord, then I suggest to use this configuration to teach your students. Just find a way to provide separate mechanical support for the power cord so that it won’t interfere much with the robot walking. Or change your robot’s project goals so that the robot stays still while you bring whatever object/target closer to a non-moving robot.

Thank you, but I’ve called robotis about my situation because my 2nd controller is the new one I’ve bought last year. So, I’m gonna send in both to be looked at. What do you think?

Also I’ve wanted my bot to be wireless as well. I have a Arbotix m controller too.

The RMA process got nothing to do with me. You better contact @Tech_Support directly.

Do you mean that your wireless module just went out also? Perhaps time to request more support from the school system to help teach your students?

I have not used the Arbotix Controller, so can’t help you there.

No sir, what I’m saying is my BT-210 wireless is ok, but it is my new cm530 controller is the one that isn’t working properly. When I hit the play button on the back of the controller I hear the tune correctly, but my bot legs does a split and does the walking but not like it supposed to be. The other controller just use the wire because the fuse box don’t work, and robotis sent me a rebuilt cm530.

If the bot did the split and then still was trying to walk (i.e., moved servos 7 through 18), then I don’t think it was a wiring issue.
For now, I am thinking more about a possible mechanical assembly issue. Do you remember that you did line up the mark on the servo’s horn to the mark on the servo’s body when you assembled the hip (i.e., servos 9, 10, 11 and 12)?
At present, can you use MANAGER and set servos 9, 10, 11 and 12 to Goal Position 512, and then somehow use a flashlight to check if the two marks I mentioned previously line up properly on these 4 servos. Can you experiment on this idea and let me know of your results?

Also, can you still do synchronized motion pages via the MOTION Tool and the real robot at the same time? Does the robot still want to do the split this way?

Sir, on the rebuilt cm530 controller everything works well walking, standing, etc it’s with the new cm530 controller.

I am assuming that you have tried “Firmware Recovery” on the new CM-530 controller too, but the problem still persists?

Yes, and I don’t know why….