Cannot catkin_make on the Ros Dynamixel SDK

I have been following this video:

I git clone the repo to a folder called src.

git clone

Then i cd to the parent folder and i type catkin_make.
However, i get this error:

/home/user1/anaconda3/bin/python3: can't find '__main__' module in '/home/user1/anaconda3/lib/python3.8/site-packages/em'

I have already done pip install em . I am using conda but i also did it in the native version with conda deactivate . I still get the same error.

When i try to install i get:

Requirement already satisfied: em in /usr/local/lib/python3.8/dist-packages (0.4.0)

I do not know how to proceed… If anyone can help me i would so so much appreciate it.

It looks to me like Python has not been configured to use the correct path. This tutorial contains steps to do so for a variety of operating systems.


After you have git clone the repo then change in to python directly and run the python script called and it will setup all the path for you :slight_smile:

The solution was this:

  1. export PYTHONPATH=$PYTHONPATH:/usr/lib/python3/dist-packages/
  2. I turned off anaconda. conda deactivate
  3. Even if you turn off anaconda, the build will still fail. You have to delete the build and devel folders that were previously built from the conda build.
  4. Reinstalled the python3-em lib

It was still failing, but after a reboot it worked.

1 Like