Dynamixel not seeing any device


The dynamixel wizard is not seeing any device when scanning.

I have followed the dynamixel wizard installation guide, made sure that I can connect to the waveshare serial bus driver board (https://www.amazon.com/dp/B0CTMM4LWK?_encoding=UTF8&psc=1&ref_=cm_sw_r_cp_ud_dp_QM0BF15V8VC3F7QT2Q3S )

Tried multiple cables, powering the board with 12V (for XL430), tried installing the dynamixel sdk and running the ping.py script but I get

Succeeded to open the port
Succeeded to change the baudrate
[TxRxResult] There is no status packet!

The XL430 blinks red once when I connect it then the led stays off.
I have verified proper connection of the GVD pins


XL430 and XL330-M288-T

DYNAMIXEL Controller:

I am using the waveshare serial bus driver board (https://www.amazon.com/dp/B0CTMM4LWK?_encoding=UTF8&psc=1&ref_=cm_sw_r_cp_ud_dp_QM0BF15V8VC3F7QT2Q3S )

Software Interface:

Ubuntu 22.04

I have looked at the Amazon web page that you shared. It did not say anything about compatibility with Robotis servos. So that is probably is the problem. Robotis servos run at half-duplex. You’ll need to get the U2D2 module.

For first time setup, you also need to connect your servos one-by-one and assign unique IDs to each unit. The default ID of 1 will produce collisions when multiple servos are connected, and will prevent the servos from being detected.

Thanks for the replies. I believe the controller I am using should be compatible, as I am following this build GitHub - AlexanderKoch-Koch/low_cost_robot where most people did not run into issues using exactly that hardware. There is one user reporting that he had tried 2 identical waveshare controllers, one had the same issue I am seeing and one worked as expected, so I may just have a bad controller.
I am testing each servo one by one.
I will try with another waveshare controller, if if I still see issue will try using u2d2.

Finally got it to work, it was a bad waveshare board. Everything worked fine with the second board that I tried this with. Thanks again for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.