Roboplus for Bioloid Premium

Is it necessary to download and install the RoboPlus software in order for the Bioloid Premium robot to work correctly? If it is then I have a problem as I only have use of my iMac (running 10.14.6 Mojave OS) and not a PC. I have seen that two other parts of the Robotis software suite that use Mac OS so maybe these will suffice? This is my first venture into robotics so I have no experience in this field

Hello @rodleach, thank you for your post and for joining our community! I’ll be glad to provide some additional information to get you started with the BIOLOID Premium robot. To begin, allow me to link our online product manual for the BIOLOID Premium robot kit, which has some instructions you will find useful while working with the kit. Regarding your question, I will explain below:

  1. The BIOLOID Premium robot kit, like many of ROBOTIS’ kits, control the robot using signals from the includedrobot controller. For the Premium, the robot controller is the CM-530.
  2. To control the robot, the CM-530 uses program files (“task” and “motion” files) that tell it what signals to send for functions and motions in the robot.
  3. However, the BIOLOID Premium kit can be rebuilt in multiple configurations, so the CM-530 robot controller needs to use different files to control different robot figures.
  4. For the BIOLOID Premium kit, downloading those program files is the main purpose of the RoboPlus software. The Task and Motion applications provided by the software allow you to download different example program files for your robot to run. These programs also let you make your own, custom files.
    (Note: Motion files store detailed data for poses and motions in a more convenient method than writing individual Task commands. A Motion file requires a Task file to work correctly, so be sure to download both if available for your robot- Premium requires both a Task and Motion file)
  5. While the original RoboPlus software is not available for macOS, ROBOTIS has released later generations of software that support Mac users. R+ Task 2.0 and R+ Motion 2.0 are both available for macOS and can be used to download Task and Motion files (respectively) to your CM-530 controller. R+ Task 3.0 is also available but I would recommend the “2.0” versions for stability at the moment.
  6. You will need to install both R+ Task 2.0 and R+ Motion 2.0 software, and use these to download the Task file (from R+ Task 2.0) and Motion file (from R+ Motion 2.0) for the BIOLOID Premium to your robot. You can download the software through the manual pages I’ve linked to the software names above.

Hopefully this explanation helps you get started with the robot! If you have any questions let me know here and I can assist.

P.S. While it was created for a different robot kit (ROBOTIS MINI), this video from the ROBOTIS Customer Support YouTube channel also goes over the R+ Task 2.0 and R+ Motion 2.0 software which may be helpful for your reference:
As you continue using the BIOLOID Premium, I would highly recommend checking out @roboteer’s YouTube channel as well for some advanced examples with the CM-530 controller:


Hello @rodleach,

I know of another person using ROBOTIS software with a Mac and this person uses such Windows Emulator like “Parallels” (mostly effective, but not quite 100% though).



I use the Bioloid Premium with my Mac. As roboteer indicated Robotis software has worked most consistently with Windows either installed as bootcamp or using a VM through Parallels. Robotis +2.0 - both Task and Motion work pretty consistently with the Mac OS now. I have some resolution issues with Motion but you can see the entire screen. The eManuals are quite helpful and I highly recommend the books Exploring Robotis with ROBOTIS v2, and Programming Guide for ROBOTIS MINI by Chi Thai. I have learned so much from them and some “quirks” I encountered are sorted out in the books as well. Much of the MINI learnings are applicable for the Bioloid Premium…just have to adapt for the different configuration and equipment.

Good luck!

Thank you for that. I have installed the RoboTask app and downloaded the RoboMotion, but none of the servos are showing up and the do-re-me tune repeats on selecting Play and Start, without any movement from the robot. So I think that either some of the servos are faulty or the CM-530 controller has been reprogrammed (the person from whom I bought it said he shipped it having configured it with just one servo, not eighteen). Either way it might appear that I should install RoboPlus Manager to restore the original firmware and/or analyse the servos, but it is for Windows only so I have a problem!

Hello @rodleach,

I have never heard of the Manager tool constraining the CM-530 to the use of only 1 servo. Can your seller reset your CM-530 to its original firmware?

Only the MANAGER tool can reset the CM-530 firmware to its most current firmware edition, and MANAGER is a Windows only software, so you may have to invest in the Bootcamp or Parallels tools.

Maybe another possibility is this: if you bought your PREMIUM kit from ROBOTIS or one of their dealers, all the servos should be ID’s with proper IDs from 1 to 18. If the servos were provided to you “in-bulk”, then all servos ID are defaulting to “1”, and that would create IDs conflict and your TASK and MOTION codes won’t work properly. If this is the case, you will need to set each individual servo ID properly with the Dynamixel Wizard V.2 tool which does run on Mac OS. But you will need to buy a device called U2D2 ( ). That page says that U2D2 is supported in Mac-OS X!

Hang in there!

Thank you for your message. I bought the Premium from a private E-Bay seller in Italy (I am in the UK). If it is possible to reset the CM-530 by detaching it from the robot, then it might be possible to send it back to him - but I wouldn’t want to send back the whole robot! He had replaced 3 of the 18 servos so I don’t know what their ID’s are, especially as he shipped the kit saying that the controller was set up for 1 servo only. I’ll try using Parallels but I’m not ‘computer literate’ so I’m at a bit of a loss to know how to proceed (but it will teach me not to be an old dog trying new tricks in future - especially second hand ones!).

I have now achieved a download of RoboPlus Manager for Windows onto my Mac using Parallels (free Trial Version).

Connecting it to the Premium, the Manager told me that it couldn’t find any servos, so I detached the CM-530 from the robot and jiggled all the wires about.

The Manager then listed all the servos and their ID’s all checked out, and their LED’s lit when individually moved.

So I reattached the CM-530 to the robot and tried pressing Play and Start.

The robot suddenly flung its arms wide and sprang sideways, then collapsed.

Switching it off and then on again produced the warning ‘do-re-me’ repeated and nothing from the robot.

So I detached the CM-530 again, jiggled the wires and the robot briefly worked as previously, then collapsed again.

Since then I haven’t been able to get any response from the robot other than the repeated 'do-re-me sound.

Thus the problem would appear to be with either the cables or the controller?

Hello @rodleach,

It is best to take care of the CM-530 by itself first (no servos), by making sure that its firmware is updated to the most recent version first. The video shown below is a tutorial for the OpenCM-904 with MANAGER V.2 (unfortunately, I have not made one for the CM-530 with MANAGER V.2 yet), but you can adapt this procedure to your CM-530. Just Power Input to the CM-530 and USB cable from the Mac to the CM-530, and then use MANAGER V.2

If you can update the CM-530 to the latest firmware, then you are in good shape.

Next, the robot “frenzied” symptoms that you described earlier indicated that you have a few cables that have become “loose” due to previous usage (that has happened to me several times over the years). So, you can leave the servos attached to the various frame parts of your favorite robot, but you will need to isolate each servo so that you can connect only one servo (and one cable) at a time to the CM-530 and then use MANAGER V.2 to test that one servo thoroughly and update its firmware as needed (that way you can check each servo and each cable on their own). Eventually, you may have to buy a new set of cables from, your being in the UK.
to replace some or all of your existing ones.

Many thanks, Roboteer - I already ordered some new cables from RoboSavvy.
But the e-manual doesn’t list the Premium as a supported product for Manager V. 2 (only Dream, Mini and Dynamixel 2).
So is this correct, or can I install Manager v. 2 in the CM-530?

Hello @rodleach,

You are absolutely right, I forgot that the CM-530 can only be managed in MANAGER V.1 (i.e. the ROBOPLUS V. 1 software suite), available for download here. (and scroll down a bit).

And I did prepare a YouTube video for CM-530 and MANAGER V. 1 (way back in 2017).

Fortunately, you can use TASK V.3 with the CM-530.

Thank you - I have installed Robo+ Manager V. 1 in my CM-530.
But when I try to do the same with Robo+ Task 2.0 and Motion 2.0 - it says … ‘Cannot find connected controller’.
I have unplugged and replugged the controller and switched it off and on again - same result.
Also I have changed all the DMS cables that are connected to the CM-530 and now the robot sometimes works, but a lot of the time I still get the 'do-re-me- repeated sound.
It might appear the the controller has a fault but I don’t want to buy a new one if it isn’t the problem.
Frankly I don’t know what else to try!

Hello @rodleach,

Just to confirm, are you referring to the RoboPlus software that you’ve installed using Parallels?
I personally am not experienced with parallels but if you have RoboPlus you should be able to use either the original RoboPlus Task and RoboPlus Motion from that (1.0) collection, or the R+ Task 2.0 and R+ Motion 2.0 versions. Just make sure you use the same generation (1.0/2.0) for both the Task and Motion file uploads.

When you’re connecting to the R+ Manager 2.0 software, is power supplied and the CM-530 switched “on”?

Overall, it sounds like some of the existing cables may be a little loose, and the controller may need the Task and Motion files to be updated. Let’s get your connection to the software resolved and the rest should be relatively simple.
If you’re having trouble with the “1.0” and “2.0” versions, you can also try R+ Task 3.0 which will let you download Task and Motion files from the same software.

Hello @rodleach,

I am unclear about what you meant by “installed Robo+ Manager V.1 in my CM-530”. The MANAGER tool runs on your MAC with Parallels and is used to install the latest firmware into the CM-530, not the MANAGER software itself.

Did you see the list of various Dynamixels when you connected to the CM-530 via the MANAGER tool at all like in my previous video? Or did you manage to update the CM-530’s firmware itself? My previous video only shows how to use MANAGER with CM-530, and not how to update or recover its firmware, and your CM-530 may have some problems with its own memory chip too.

I did find some e-manual info about firmware recovery using MANAGER V. 1 at this link ( In there, it says something about using an LN-101, you should use your USB cable (USB-A to USB-mini). There is also a video in Korean/English on YouTube here (c. 2012):

I just did this firmware recovery procedure for my own CM-530 and it worked OK for me. Can you try and let me know your results?

Desar Chi,

Thank you for all your help.
I’ve carried out all your instructions, plus I’ve replaced all the cables.
Result - SUCCESS!
There’s just one small issue …
In the basic posture position, one of the robot’s arms is higher than the other - not by much but enough to make it collapse when it performs push-ups etc.
I expect that something in the e-manual will deal with this, but if you can point me in the right direction I’d be most grateful.
Thank you again - Rod.

Hello @rodleach,

Good to hear that things are working out for you. Your present issue involves the Offset settings of the “offending” servo(s). You can do it in TASK V.3 or MOTION V.2. In the picture below (TASK 3) look for the last item of the menu on the right:

The e-manual has good info for this mode listed for TASK 3 or Motion V.2 at these links. (probably better for you).

You will need to put the robot into that “All-zero-degree” position for all servos, before adjusting the “offending” servos (probably one of the servos 1 through 6. It is going to be “trial-and-error”

If the feet seem to be interfering with each other too much, you can try to set Servos 7 & 8 like shown below, before fixing up servos 1 through 6.

But watch out, remember to clear the offsets for Servos 7 & 8 back to zero before you save the “new” offset values for Servos 1 through 6 into the memory of the CM-530. If NOT, your robot is going to walk “funny” (if at all) from then on, if those -45 and 45 values are not cleared to 0 for servos 7 & 8. Come to think of it, it may walk like Charlie Chaplin in those old movies!

Thank you - again.
However the robot will not connect to either Task v.3 or Motion v.2.
I have tried uninstalling and reinstalling both, but it steadfastly refuses to connect.
(It does however connect to Motion v.1 and Task v.1.
I’m not sure what else to try?
Yours - Rod.
PS - The initial posture in Task v.3 and Motion v.2 shows the robot with arms stretched out wide, whereas the Quick Start manual shows it with its arms down, slightly forward.

Hi @rodleach,

It’s great to hear you were able to resolve the issue with the loose cables & controller communication. As @roboteer mentioned I believe the difference in the arm’s positions should be fixable using the Offset settings.

R+ Motion 2.0 and R+ Task 3.0 have the most updated versions of those tools, but it can also be done using RoboPlus Motion (1.0) by following the instructions at the following link:

This version of the offset editor may involve some “guess-and-check” as you will need to identify the ID number to offset, change its value, and then download the offset file using the (1.0) Motion software to see its effects.
To help with the offset values, this image might be helpful. “Zero” in the offset editor should be at the 12:00 position that is labeled “Goal Position: 512”

For the connection with the R+ Motion 2.0 or R+ Task 3.0 software- have these been updated to the latest version? You should be able to check the software’s update availability using the “refresh symbol” on the home page of both programs.

Please use the special “word” “@roboteer” in your posting so that this community web site will notify me that there is a message for me. I do not log on this Community web site everyday.

Back to your current issue: I do not have a Mac so I can’t help with the issue of TASK V.3 or MOTION V.2 not connecting with the CM-530. I can certify that on Windows 10, I can use MOTION V.2 and TASK V.3 with a CM-530 fine. The only thing that I can suggest is to make sure that only ONE program, either MANAGER or TASK or MOTION is running at any one time, because that particular COM port between your desktop and CM-530 is used and not available to other programs to use. For example, if you have MOTION V.1 connected to the robot, no other tool will be able to connect to the robot, until you terminate MOTION 1.
The robot needs to be put in the “special” calibration pose when you need to adjust the OFFSET values, that pose is not part of the demo MOTION file for your robot. You have to create a NEW Calibration POSE (in Motion 1) or MOTION UNIT (in Motion 2 and Task 3). In Motion 1, the value to use is “512” for the “Center Goal Position” of each servo. In Task 3 and Motion 2, they use a relative angle in degree with respect to this Goal Position “512”, that is why the Calibration pose is set with “0” when using Task 3 or Motion 2.

Well - so far you’ve picked up every message and have responded way beyond the ‘call of duty’ - for which I’m more than grateful.
To bring you (RobotisCommunity and Roboteer) up to date …
I’ve used R+ Motion v.1 to check each servo operation.
When I toggle the movement in Edit mode, each servo is operating properly - except No. 1 (which controls the overall left arm position).
This initially moves a little and then not at all.
I find this strange, as in Demo Mode, No. 1 servo is working all through its range; also when using the remote to perform manoeuvres requiring full movement.
The one problem is, as I’ve previously written, is in the basic posture for No. 1 servo in Demo Mode.
I have ordered a replacement servo, but maybe this will be a waste of money … we shall see!