ROS2 (Humble) + Dynamixel Error

I’m using ROS2 Humble to control 2XL430-W250-T connected via U2D2
I followed this Video-Tutorial:

Everything goes right until this command:

ros2 topic pub /set_position dynamixel_sdk_custom_interfaces/msg/SetPosition 

after SetPosition, normally by pressing Tab, It should looks like in the video:

ros2 topic pub /set_position dynamixel_sdk_custom_interfaces/msg/SetPosition "{id: 1, position: 1000}"

but unfortunately, it’s not working!! and typing by myself is not solve the problem.

I also tried publishing this topic (set_position) using rqt but when I want to add, it causes crash!
crash title is:
ModuleNotFoundError: No module named ‘dynamixel_sdk_custom_interfaces’

There is “dynamixel_sdk_custom_interfaces” folder:


Please help me.

Hi @alikhorshidi

I’m sorry about the delayed response.
I’ll test this on my PC and give you an update!


When I tested with my XL430-W250-T (ID=1, Baudrate=57600), this worked fine on ROS2 Humble as below.



If you are getting the missing module error, please make sure that the correct GitHub source code branch(humble-devel) is downloaded and compiled.

This can be checked with the command below under your DynamixelSDK folder

$ cd ~/robotis_ws/src/DynamixelSDK
$ git branch checkout humble-devel

You should see something like this.

Then, the setup.bash must be sourced as below. I had this command in the .bashrc file.

$ source ~/robotis_ws/install/local_setup.bash


this is where I source ROS setup in the .bashrc file.